[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH v7 5/5] accel: abort if we fail to load the accelerator plugi
From: |
Markus Armbruster |
Subject: |
Re: [PATCH v7 5/5] accel: abort if we fail to load the accelerator plugin |
Date: |
Wed, 28 Sep 2022 10:28:06 +0200 |
User-agent: |
Gnus/5.13 (Gnus v5.13) Emacs/27.2 (gnu/linux) |
Claudio Fontana <cfontana@suse.de> writes:
> if QEMU is configured with modules enabled, it is possible that the
> load of an accelerator module will fail.
> Abort in this case, relying on module_object_class_by_name to report
> the specific load error if any.
>
> Signed-off-by: Claudio Fontana <cfontana@suse.de>
> Reviewed-by: Richard Henderson <richard.henderson@linaro.org>
>
> [claudio: changed abort() to exit(1)]
> Reviewed-by: Philippe Mathieu-Daudé <f4bug@amsat.org>
> ---
> accel/accel-softmmu.c | 8 +++++++-
> 1 file changed, 7 insertions(+), 1 deletion(-)
>
> diff --git a/accel/accel-softmmu.c b/accel/accel-softmmu.c
> index 67276e4f52..f9cdafb148 100644
> --- a/accel/accel-softmmu.c
> +++ b/accel/accel-softmmu.c
> @@ -66,6 +66,7 @@ void accel_init_ops_interfaces(AccelClass *ac)
> {
> const char *ac_name;
> char *ops_name;
> + ObjectClass *oc;
> AccelOpsClass *ops;
>
> ac_name = object_class_get_name(OBJECT_CLASS(ac));
> @@ -73,8 +74,13 @@ void accel_init_ops_interfaces(AccelClass *ac)
>
> ops_name = g_strdup_printf("%s" ACCEL_OPS_SUFFIX, ac_name);
> ops = ACCEL_OPS_CLASS(module_object_class_by_name(ops_name));
> + oc = module_object_class_by_name(ops_name);
> + if (!oc) {
> + error_report("fatal: could not load module for type '%s'", ops_name);
I'm not sure the additional error message is worth it.
> + exit(1);
Commit message claims we abort, but we don't, we terminate
unsuccessfully. Easy enough to fix :)
> + }
> g_free(ops_name);
> -
> + ops = ACCEL_OPS_CLASS(oc);
> /*
> * all accelerators need to define ops, providing at least a mandatory
> * non-NULL create_vcpu_thread operation.
With the commit message corrected:
Reviewed-by: Markus Armbruster <armbru@redhat.com>
- [PATCH v7 0/5] improve error handling for module load, Claudio Fontana, 2022/09/27
- [PATCH v7 2/5] module: rename module_load_one to module_load, Claudio Fontana, 2022/09/27
- [PATCH v7 3/5] module: add Error arguments to module_load and module_load_qom, Claudio Fontana, 2022/09/27
- [PATCH v7 1/5] module: removed unused function argument "mayfail", Claudio Fontana, 2022/09/27
- [PATCH v7 4/5] dmg: warn when opening dmg images containing blocks of unknown type, Claudio Fontana, 2022/09/27
- [PATCH v7 5/5] accel: abort if we fail to load the accelerator plugin, Claudio Fontana, 2022/09/27
- Re: [PATCH v7 5/5] accel: abort if we fail to load the accelerator plugin,
Markus Armbruster <=