qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[PULL 08/67] hw/sd/sdcard: Use READY_FOR_DATA definition instead of magi


From: Philippe Mathieu-Daudé
Subject: [PULL 08/67] hw/sd/sdcard: Use READY_FOR_DATA definition instead of magic value
Date: Tue, 2 Jul 2024 11:19:51 +0200

Signed-off-by: Philippe Mathieu-Daudé <philmd@linaro.org>
Tested-by: Cédric Le Goater <clg@redhat.com>
Reviewed-by: Cédric Le Goater <clg@redhat.com>
Message-Id: <20240628070216.92609-10-philmd@linaro.org>
---
 hw/sd/sd.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/hw/sd/sd.c b/hw/sd/sd.c
index 54bb0ff1c9..04ca895645 100644
--- a/hw/sd/sd.c
+++ b/hw/sd/sd.c
@@ -559,7 +559,7 @@ FIELD(CSR, OUT_OF_RANGE,               31,  1)
 
 static void sd_set_cardstatus(SDState *sd)
 {
-    sd->card_status = 0x00000100;
+    sd->card_status = READY_FOR_DATA;
 }
 
 static void sd_set_sdstatus(SDState *sd)
-- 
2.41.0




reply via email to

[Prev in Thread] Current Thread [Next in Thread]