[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PULL v2 76/88] hw/cxl/events: Mark cxl-add-dynamic-capacity and cxl-rel
From: |
Michael S. Tsirkin |
Subject: |
[PULL v2 76/88] hw/cxl/events: Mark cxl-add-dynamic-capacity and cxl-release-dynamic-capcity unstable |
Date: |
Tue, 2 Jul 2024 16:20:13 -0400 |
From: Jonathan Cameron <Jonathan.Cameron@huawei.com>
Markus suggested that we make the unstable. I don't expect these
interfaces to change because of their tight coupling to the Compute
Express Link (CXL) Specification, Revision 3.1 Fabric Management API
definitions which can only be extended in backwards compatible way.
However, there seems little disadvantage in taking a cautious path
for now and marking them as unstable interfaces.
Suggested-by: Markus Armbruster <armbru@redhat.com>
Signed-off-by: Jonathan Cameron <Jonathan.Cameron@huawei.com>
Message-Id: <20240625170805.359278-3-Jonathan.Cameron@huawei.com>
Reviewed-by: Michael S. Tsirkin <mst@redhat.com>
Signed-off-by: Michael S. Tsirkin <mst@redhat.com>
---
qapi/cxl.json | 14 ++++++++++++--
1 file changed, 12 insertions(+), 2 deletions(-)
diff --git a/qapi/cxl.json b/qapi/cxl.json
index a38622a0d1..bdfac67c47 100644
--- a/qapi/cxl.json
+++ b/qapi/cxl.json
@@ -453,6 +453,10 @@
# @extents: The "Extent List" field as defined in Compute Express Link
# (CXL) Specification, Revision 3.1, Table 7-70.
#
+# Features:
+#
+# @unstable: For now this command is subject to change.
+#
# Since : 9.1
##
{ 'command': 'cxl-add-dynamic-capacity',
@@ -462,7 +466,8 @@
'region': 'uint8',
'*tag': 'str',
'extents': [ 'CxlDynamicCapacityExtent' ]
- }
+ },
+ 'features': [ 'unstable' ]
}
##
@@ -527,6 +532,10 @@
# @extents: The "Extent List" field as defined in Compute Express
# Link (CXL) Specification, Revision 3.1, Table 7-71.
#
+# Features:
+#
+# @unstable: For now this command is subject to change.
+#
# Since : 9.1
##
{ 'command': 'cxl-release-dynamic-capacity',
@@ -538,5 +547,6 @@
'region': 'uint8',
'*tag': 'str',
'extents': [ 'CxlDynamicCapacityExtent' ]
- }
+ },
+ 'features': [ 'unstable' ]
}
--
MST
- [PULL v2 66/88] qtest: bios-tables-test: Rename aarch64 tests with aarch64 in them, (continued)
- [PULL v2 66/88] qtest: bios-tables-test: Rename aarch64 tests with aarch64 in them, Michael S. Tsirkin, 2024/07/02
- [PULL v2 65/88] tests/data/uefi-boot-images: Add RISC-V ISO image, Michael S. Tsirkin, 2024/07/02
- [PULL v2 67/88] tests/qtest/bios-tables-test.c: Add support for arch in path, Michael S. Tsirkin, 2024/07/02
- [PULL v2 68/88] tests/qtest/bios-tables-test.c: Set "arch" for aarch64 tests, Michael S. Tsirkin, 2024/07/02
- [PULL v2 69/88] tests/qtest/bios-tables-test.c: Set "arch" for x86 tests, Michael S. Tsirkin, 2024/07/02
- [PULL v2 70/88] tests/data/acpi: Move x86 ACPI tables under x86/${machine} path, Michael S. Tsirkin, 2024/07/02
- [PULL v2 71/88] tests/data/acpi/virt: Move ARM64 ACPI tables under aarch64/${machine} path, Michael S. Tsirkin, 2024/07/02
- [PULL v2 73/88] pc-bios/meson.build: Add support for RISC-V in unpack_edk2_blobs, Michael S. Tsirkin, 2024/07/02
- [PULL v2 74/88] tests/data/acpi/rebuild-expected-aml.sh: Add RISC-V, Michael S. Tsirkin, 2024/07/02
- [PULL v2 72/88] meson.build: Add RISC-V to the edk2-target list, Michael S. Tsirkin, 2024/07/02
- [PULL v2 76/88] hw/cxl/events: Mark cxl-add-dynamic-capacity and cxl-release-dynamic-capcity unstable,
Michael S. Tsirkin <=
- [PULL v2 77/88] virtio: remove virtio_tswap16s() call in vring_packed_event_read(), Michael S. Tsirkin, 2024/07/02
- [PULL v2 75/88] hw/cxl/events: Improve QMP interfaces and documentation for add/release dynamic capacity., Michael S. Tsirkin, 2024/07/02
- [PULL v2 78/88] virtio-iommu: Clear IOMMUDevice when VFIO device is unplugged, Michael S. Tsirkin, 2024/07/02
- [PULL v2 80/88] hw/ppc/spapr_pci: Do not create DT for disabled PCI device, Michael S. Tsirkin, 2024/07/02
- [PULL v2 79/88] hw/pci: Rename has_power to enabled, Michael S. Tsirkin, 2024/07/02
- [PULL v2 85/88] pcie_sriov: Release VFs failed to realize, Michael S. Tsirkin, 2024/07/02
- [PULL v2 82/88] pcie_sriov: Do not manually unrealize, Michael S. Tsirkin, 2024/07/02
- [PULL v2 83/88] pcie_sriov: Ensure VF function number does not overflow, Michael S. Tsirkin, 2024/07/02
- [PULL v2 84/88] pcie_sriov: Reuse SR-IOV VF device instances, Michael S. Tsirkin, 2024/07/02
- [PULL v2 87/88] pcie_sriov: Register VFs after migration, Michael S. Tsirkin, 2024/07/02