[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PULL v2 88/88] hw/pci: Replace -1 with UINT32_MAX for romsize
From: |
Michael S. Tsirkin |
Subject: |
[PULL v2 88/88] hw/pci: Replace -1 with UINT32_MAX for romsize |
Date: |
Tue, 2 Jul 2024 16:21:03 -0400 |
From: Akihiko Odaki <akihiko.odaki@daynix.com>
romsize is an uint32_t variable. Specifying -1 as an uint32_t value is
obscure way to denote UINT32_MAX.
Worse, if int is wider than 32-bit, it will change the behavior of a
construct like the following:
romsize = -1;
if (romsize != -1) {
...
}
When -1 is assigned to romsize, -1 will be implicitly casted into
uint32_t, resulting in UINT32_MAX. On contrary, when evaluating
romsize != -1, romsize will be casted into int, and it will be a
comparison of UINT32_MAX and -1, and result in false.
Replace -1 with UINT32_MAX for statements involving the variable to
clarify the intent and prevent potential breakage.
Signed-off-by: Akihiko Odaki <akihiko.odaki@daynix.com>
Reviewed-by: Markus Armbruster <armbru@redhat.com>
Message-Id: <20240627-reuse-v10-10-7ca0b8ed3d9f@daynix.com>
Reviewed-by: Michael S. Tsirkin <mst@redhat.com>
Signed-off-by: Michael S. Tsirkin <mst@redhat.com>
---
hw/pci/pci.c | 8 ++++----
hw/xen/xen_pt_load_rom.c | 2 +-
2 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/hw/pci/pci.c b/hw/pci/pci.c
index fa85f87b1c..4c7be52951 100644
--- a/hw/pci/pci.c
+++ b/hw/pci/pci.c
@@ -70,7 +70,7 @@ static bool pcie_has_upstream_port(PCIDevice *dev);
static Property pci_props[] = {
DEFINE_PROP_PCI_DEVFN("addr", PCIDevice, devfn, -1),
DEFINE_PROP_STRING("romfile", PCIDevice, romfile),
- DEFINE_PROP_UINT32("romsize", PCIDevice, romsize, -1),
+ DEFINE_PROP_UINT32("romsize", PCIDevice, romsize, UINT32_MAX),
DEFINE_PROP_UINT32("rombar", PCIDevice, rom_bar, 1),
DEFINE_PROP_BIT("multifunction", PCIDevice, cap_present,
QEMU_PCI_CAP_MULTIFUNCTION_BITNR, false),
@@ -2073,7 +2073,7 @@ static void pci_qdev_realize(DeviceState *qdev, Error
**errp)
g_cmp_uint32, NULL);
}
- if (pci_dev->romsize != -1 && !is_power_of_2(pci_dev->romsize)) {
+ if (pci_dev->romsize != UINT32_MAX && !is_power_of_2(pci_dev->romsize)) {
error_setg(errp, "ROM size %u is not a power of two",
pci_dev->romsize);
return;
}
@@ -2359,7 +2359,7 @@ static void pci_add_option_rom(PCIDevice *pdev, bool
is_default_rom,
return;
}
- if (load_file || pdev->romsize == -1) {
+ if (load_file || pdev->romsize == UINT32_MAX) {
path = qemu_find_file(QEMU_FILE_TYPE_BIOS, pdev->romfile);
if (path == NULL) {
path = g_strdup(pdev->romfile);
@@ -2378,7 +2378,7 @@ static void pci_add_option_rom(PCIDevice *pdev, bool
is_default_rom,
pdev->romfile);
return;
}
- if (pdev->romsize != -1) {
+ if (pdev->romsize != UINT_MAX) {
if (size > pdev->romsize) {
error_setg(errp, "romfile \"%s\" (%u bytes) "
"is too large for ROM size %u",
diff --git a/hw/xen/xen_pt_load_rom.c b/hw/xen/xen_pt_load_rom.c
index 03422a8a71..6bc64acd33 100644
--- a/hw/xen/xen_pt_load_rom.c
+++ b/hw/xen/xen_pt_load_rom.c
@@ -53,7 +53,7 @@ void *pci_assign_dev_load_option_rom(PCIDevice *dev,
}
fseek(fp, 0, SEEK_SET);
- if (dev->romsize != -1) {
+ if (dev->romsize != UINT_MAX) {
if (st.st_size > dev->romsize) {
error_report("ROM BAR \"%s\" (%ld bytes) is too large for ROM size
%u",
rom_file, (long) st.st_size, dev->romsize);
--
MST
- [PULL v2 78/88] virtio-iommu: Clear IOMMUDevice when VFIO device is unplugged, (continued)
- [PULL v2 78/88] virtio-iommu: Clear IOMMUDevice when VFIO device is unplugged, Michael S. Tsirkin, 2024/07/02
- [PULL v2 80/88] hw/ppc/spapr_pci: Do not create DT for disabled PCI device, Michael S. Tsirkin, 2024/07/02
- [PULL v2 79/88] hw/pci: Rename has_power to enabled, Michael S. Tsirkin, 2024/07/02
- [PULL v2 85/88] pcie_sriov: Release VFs failed to realize, Michael S. Tsirkin, 2024/07/02
- [PULL v2 82/88] pcie_sriov: Do not manually unrealize, Michael S. Tsirkin, 2024/07/02
- [PULL v2 83/88] pcie_sriov: Ensure VF function number does not overflow, Michael S. Tsirkin, 2024/07/02
- [PULL v2 84/88] pcie_sriov: Reuse SR-IOV VF device instances, Michael S. Tsirkin, 2024/07/02
- [PULL v2 87/88] pcie_sriov: Register VFs after migration, Michael S. Tsirkin, 2024/07/02
- [PULL v2 81/88] hw/ppc/spapr_pci: Do not reject VFs created after a PF, Michael S. Tsirkin, 2024/07/02
- [PULL v2 86/88] pcie_sriov: Remove num_vfs from PCIESriovPF, Michael S. Tsirkin, 2024/07/02
- [PULL v2 88/88] hw/pci: Replace -1 with UINT32_MAX for romsize,
Michael S. Tsirkin <=
- Re: [PULL v2 00/88] virtio: features,fixes, Richard Henderson, 2024/07/03
- Re: [PULL v2 00/88] virtio: features,fixes, Michael S. Tsirkin, 2024/07/03
- Re: [PULL v2 00/88] virtio: features,fixes, Richard Henderson, 2024/07/03
- Re: [PULL v2 00/88] virtio: features,fixes, Thomas Huth, 2024/07/03
- Re: [PULL v2 00/88] virtio: features,fixes, Michael S. Tsirkin, 2024/07/03
- Re: [PULL v2 00/88] virtio: features,fixes, Michael S. Tsirkin, 2024/07/03
- Re: [PULL v2 00/88] virtio: features,fixes, Thomas Huth, 2024/07/04
- Re: [PULL v2 00/88] virtio: features,fixes, Michael S. Tsirkin, 2024/07/03
- Re: [PULL v2 00/88] virtio: features,fixes, Richard Henderson, 2024/07/03
- Re: [PULL v2 00/88] virtio: features,fixes, Michael S. Tsirkin, 2024/07/03