[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PULL v3 74/85] virtio: remove virtio_tswap16s() call in vring_packed_ev
From: |
Michael S. Tsirkin |
Subject: |
[PULL v3 74/85] virtio: remove virtio_tswap16s() call in vring_packed_event_read() |
Date: |
Wed, 3 Jul 2024 18:49:57 -0400 |
From: Stefano Garzarella <sgarzare@redhat.com>
Commit d152cdd6f6 ("virtio: use virtio accessor to access packed event")
switched using of address_space_read_cached() to virito_lduw_phys_cached()
to access packed descriptor event.
When we used address_space_read_cached(), we needed to call
virtio_tswap16s() to handle the endianess of the field, but
virito_lduw_phys_cached() already handles it internally, so we no longer
need to call virtio_tswap16s() (as the commit had done for `off_wrap`,
but forgot for `flags`).
Fixes: d152cdd6f6 ("virtio: use virtio accessor to access packed event")
Cc: jasowang@redhat.com
Cc: qemu-stable@nongnu.org
Reported-by: Xoykie <xoykie@gmail.com>
Link:
https://lore.kernel.org/qemu-devel/CAFU8RB_pjr77zMLsM0Unf9xPNxfr_--Tjr49F_eX32ZBc5o2zQ@mail.gmail.com
Signed-off-by: Stefano Garzarella <sgarzare@redhat.com>
Message-Id: <20240701075208.19634-1-sgarzare@redhat.com>
Acked-by: Jason Wang <jasowang@redhat.com>
Reviewed-by: Peter Maydell <peter.maydell@linaro.org>
Reviewed-by: Eugenio PĂ©rez <eperezma@redhat.com>
Reviewed-by: Michael S. Tsirkin <mst@redhat.com>
Signed-off-by: Michael S. Tsirkin <mst@redhat.com>
---
hw/virtio/virtio.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/hw/virtio/virtio.c b/hw/virtio/virtio.c
index 3678ec2f88..583a224163 100644
--- a/hw/virtio/virtio.c
+++ b/hw/virtio/virtio.c
@@ -323,7 +323,6 @@ static void vring_packed_event_read(VirtIODevice *vdev,
/* Make sure flags is seen before off_wrap */
smp_rmb();
e->off_wrap = virtio_lduw_phys_cached(vdev, cache, off_off);
- virtio_tswap16s(vdev, &e->flags);
}
static void vring_packed_off_wrap_write(VirtIODevice *vdev,
--
MST
- [PULL v3 63/85] qtest: bios-tables-test: Rename aarch64 tests with aarch64 in them, (continued)
- [PULL v3 63/85] qtest: bios-tables-test: Rename aarch64 tests with aarch64 in them, Michael S. Tsirkin, 2024/07/03
- [PULL v3 64/85] tests/qtest/bios-tables-test.c: Add support for arch in path, Michael S. Tsirkin, 2024/07/03
- [PULL v3 65/85] tests/qtest/bios-tables-test.c: Set "arch" for aarch64 tests, Michael S. Tsirkin, 2024/07/03
- [PULL v3 67/85] tests/data/acpi: Move x86 ACPI tables under x86/${machine} path, Michael S. Tsirkin, 2024/07/03
- [PULL v3 66/85] tests/qtest/bios-tables-test.c: Set "arch" for x86 tests, Michael S. Tsirkin, 2024/07/03
- [PULL v3 68/85] tests/data/acpi/virt: Move ARM64 ACPI tables under aarch64/${machine} path, Michael S. Tsirkin, 2024/07/03
- [PULL v3 70/85] pc-bios/meson.build: Add support for RISC-V in unpack_edk2_blobs, Michael S. Tsirkin, 2024/07/03
- [PULL v3 71/85] tests/data/acpi/rebuild-expected-aml.sh: Add RISC-V, Michael S. Tsirkin, 2024/07/03
- [PULL v3 72/85] hw/cxl/events: Improve QMP interfaces and documentation for add/release dynamic capacity., Michael S. Tsirkin, 2024/07/03
- [PULL v3 73/85] hw/cxl/events: Mark cxl-add-dynamic-capacity and cxl-release-dynamic-capcity unstable, Michael S. Tsirkin, 2024/07/03
- [PULL v3 74/85] virtio: remove virtio_tswap16s() call in vring_packed_event_read(),
Michael S. Tsirkin <=
- [PULL v3 75/85] virtio-iommu: Clear IOMMUDevice when VFIO device is unplugged, Michael S. Tsirkin, 2024/07/03
- [PULL v3 76/85] hw/pci: Rename has_power to enabled, Michael S. Tsirkin, 2024/07/03
- [PULL v3 77/85] hw/ppc/spapr_pci: Do not create DT for disabled PCI device, Michael S. Tsirkin, 2024/07/03
- [PULL v3 78/85] hw/ppc/spapr_pci: Do not reject VFs created after a PF, Michael S. Tsirkin, 2024/07/03
- [PULL v3 79/85] pcie_sriov: Do not manually unrealize, Michael S. Tsirkin, 2024/07/03
- [PULL v3 80/85] pcie_sriov: Ensure VF function number does not overflow, Michael S. Tsirkin, 2024/07/03
- [PULL v3 81/85] pcie_sriov: Reuse SR-IOV VF device instances, Michael S. Tsirkin, 2024/07/03
- [PULL v3 82/85] pcie_sriov: Release VFs failed to realize, Michael S. Tsirkin, 2024/07/03
- [PULL v3 83/85] pcie_sriov: Remove num_vfs from PCIESriovPF, Michael S. Tsirkin, 2024/07/03
- [PULL v3 84/85] pcie_sriov: Register VFs after migration, Michael S. Tsirkin, 2024/07/03