[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH 07/17] bsd-user: Remove deprecated -p argument
From: |
Warner Losh |
Subject: |
[PATCH 07/17] bsd-user: Remove deprecated -p argument |
Date: |
Fri, 2 Aug 2024 17:56:07 -0600 |
FreeBSD never really used the -p argument, so it's safe to remove
entirely.
Signed-off-by: Warner Losh <imp@bsdimp.com>
---
bsd-user/main.c | 8 --------
1 file changed, 8 deletions(-)
diff --git a/bsd-user/main.c b/bsd-user/main.c
index 9ad31bd1efe..709ab10ddc1 100644
--- a/bsd-user/main.c
+++ b/bsd-user/main.c
@@ -388,14 +388,6 @@ int main(int argc, char **argv)
}
} else if (!strcmp(r, "L")) {
interp_prefix = argv[optind++];
- } else if (!strcmp(r, "p")) {
- unsigned size, want = qemu_real_host_page_size();
-
- r = argv[optind++];
- if (qemu_strtoui(r, NULL, 10, &size) || size != want) {
- warn_report("Deprecated page size option cannot "
- "change host page size (%u)", want);
- }
} else if (!strcmp(r, "g")) {
gdbstub = g_strdup(argv[optind++]);
} else if (!strcmp(r, "r")) {
--
2.45.1
- [PATCH 02/17] bsd-user: Make init_task_state global, (continued)
- [PATCH 02/17] bsd-user: Make init_task_state global, Warner Losh, 2024/08/02
- [PATCH 04/17] bsd-user: Implement cpu_copy(), Warner Losh, 2024/08/02
- [PATCH 05/17] bsd-user: Eliminate unused regs arg in load_elf_binary, Warner Losh, 2024/08/02
- [PATCH 12/17] bsd-user: Use guest_range_valid_untagged to validate range, Warner Losh, 2024/08/02
- [PATCH 03/17] bsd-user: Make cpu_model and cpu_type file scope, Warner Losh, 2024/08/02
- [PATCH 07/17] bsd-user: Remove deprecated -p argument,
Warner Losh <=
- [PATCH 08/17] bsd-user: Eliminate unused qemu_uname_release, Warner Losh, 2024/08/02
- [PATCH 06/17] bsd-user: Remove load_flt_binary prototype, Warner Losh, 2024/08/02
- [PATCH 11/17] bsd-user: Replace set_brk and padzero with zerobss from linux-user, Warner Losh, 2024/08/02
- [PATCH 13/17] bsd-user: target_mprotect: rename prot to target_prot, Warner Losh, 2024/08/02
- [PATCH 09/17] bsd-user: target_msync unused, remove it, Warner Losh, 2024/08/02