[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH for-9.2 v12 04/11] pcie_sriov: Do not manually unrealize
From: |
Akihiko Odaki |
Subject: |
[PATCH for-9.2 v12 04/11] pcie_sriov: Do not manually unrealize |
Date: |
Sun, 04 Aug 2024 18:01:40 +0900 |
A device gets automatically unrealized when being unparented.
Signed-off-by: Akihiko Odaki <akihiko.odaki@daynix.com>
---
hw/pci/pcie_sriov.c | 4 ----
1 file changed, 4 deletions(-)
diff --git a/hw/pci/pcie_sriov.c b/hw/pci/pcie_sriov.c
index e9b23221d713..499becd5273f 100644
--- a/hw/pci/pcie_sriov.c
+++ b/hw/pci/pcie_sriov.c
@@ -204,11 +204,7 @@ static void unregister_vfs(PCIDevice *dev)
trace_sriov_unregister_vfs(dev->name, PCI_SLOT(dev->devfn),
PCI_FUNC(dev->devfn), num_vfs);
for (i = 0; i < num_vfs; i++) {
- Error *err = NULL;
PCIDevice *vf = dev->exp.sriov_pf.vf[i];
- if (!object_property_set_bool(OBJECT(vf), "realized", false, &err)) {
- error_reportf_err(err, "Failed to unplug: ");
- }
object_unparent(OBJECT(vf));
object_unref(OBJECT(vf));
}
--
2.45.2
- [PATCH for-9.2 v12 00/11] hw/pci: SR-IOV related fixes and improvements, Akihiko Odaki, 2024/08/04
- [PATCH for-9.2 v12 01/11] hw/pci: Rename has_power to enabled, Akihiko Odaki, 2024/08/04
- [PATCH for-9.2 v12 02/11] hw/ppc/spapr_pci: Do not create DT for disabled PCI device, Akihiko Odaki, 2024/08/04
- [PATCH for-9.2 v12 03/11] hw/ppc/spapr_pci: Do not reject VFs created after a PF, Akihiko Odaki, 2024/08/04
- [PATCH for-9.2 v12 04/11] pcie_sriov: Do not manually unrealize,
Akihiko Odaki <=
- [PATCH for-9.2 v12 05/11] pcie_sriov: Ensure VF function number does not overflow, Akihiko Odaki, 2024/08/04
- [PATCH for-9.2 v12 06/11] pcie_sriov: Reuse SR-IOV VF device instances, Akihiko Odaki, 2024/08/04
- [PATCH for-9.2 v12 07/11] pcie_sriov: Release VFs failed to realize, Akihiko Odaki, 2024/08/04
- [PATCH for-9.2 v12 08/11] pcie_sriov: Remove num_vfs from PCIESriovPF, Akihiko Odaki, 2024/08/04
- [PATCH for-9.2 v12 09/11] pcie_sriov: Register VFs after migration, Akihiko Odaki, 2024/08/04
- [PATCH for-9.2 v12 10/11] hw/pci: Use -1 as the default value for rombar, Akihiko Odaki, 2024/08/04
- [PATCH for-9.2 v12 11/11] hw/qdev: Remove opts member, Akihiko Odaki, 2024/08/04
- Re: [PATCH for-9.2 v12 00/11] hw/pci: SR-IOV related fixes and improvements, Michael S. Tsirkin, 2024/08/05