[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v16 09/13] pcie_sriov: Release VFs failed to realize
From: |
Akihiko Odaki |
Subject: |
[PATCH v16 09/13] pcie_sriov: Release VFs failed to realize |
Date: |
Fri, 13 Sep 2024 12:44:37 +0900 |
Release VFs failed to realize just as we do in unregister_vfs().
Fixes: 7c0fa8dff811 ("pcie: Add support for Single Root I/O Virtualization
(SR/IOV)")
Signed-off-by: Akihiko Odaki <akihiko.odaki@daynix.com>
---
hw/pci/pcie_sriov.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/hw/pci/pcie_sriov.c b/hw/pci/pcie_sriov.c
index 4bffe6c97f66..ac8c4013bc88 100644
--- a/hw/pci/pcie_sriov.c
+++ b/hw/pci/pcie_sriov.c
@@ -87,6 +87,8 @@ bool pcie_sriov_pf_init(PCIDevice *dev, uint16_t offset,
vf->exp.sriov_vf.vf_number = i;
if (!qdev_realize(&vf->qdev, bus, errp)) {
+ object_unparent(OBJECT(vf));
+ object_unref(vf);
unparent_vfs(dev, i);
return false;
}
--
2.46.0
- [PATCH v16 00/13] hw/pci: SR-IOV related fixes and improvements, Akihiko Odaki, 2024/09/12
- [PATCH v16 01/13] hw/pci: Rename has_power to enabled, Akihiko Odaki, 2024/09/12
- [PATCH v16 02/13] hw/ppc/spapr_pci: Do not create DT for disabled PCI device, Akihiko Odaki, 2024/09/12
- [PATCH v16 03/13] hw/ppc/spapr_pci: Do not reject VFs created after a PF, Akihiko Odaki, 2024/09/12
- [PATCH v16 04/13] s390x/pci: Avoid creating zpci for VFs, Akihiko Odaki, 2024/09/12
- [PATCH v16 05/13] s390x/pci: Allow plugging SR-IOV devices, Akihiko Odaki, 2024/09/12
- [PATCH v16 06/13] s390x/pci: Check for multifunction after device realization, Akihiko Odaki, 2024/09/12
- [PATCH v16 07/13] pcie_sriov: Do not manually unrealize, Akihiko Odaki, 2024/09/12
- [PATCH v16 08/13] pcie_sriov: Reuse SR-IOV VF device instances, Akihiko Odaki, 2024/09/12
- [PATCH v16 09/13] pcie_sriov: Release VFs failed to realize,
Akihiko Odaki <=
- [PATCH v16 10/13] pcie_sriov: Remove num_vfs from PCIESriovPF, Akihiko Odaki, 2024/09/12
- [PATCH v16 11/13] pcie_sriov: Register VFs after migration, Akihiko Odaki, 2024/09/12
- [PATCH v16 12/13] hw/pci: Use -1 as the default value for rombar, Akihiko Odaki, 2024/09/12
- [PATCH v16 13/13] hw/qdev: Remove opts member, Akihiko Odaki, 2024/09/12