[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v4 05/15] acpi/ghes: Fix acpi_ghes_record_errors() argument
From: |
Mauro Carvalho Chehab |
Subject: |
[PATCH v4 05/15] acpi/ghes: Fix acpi_ghes_record_errors() argument |
Date: |
Fri, 22 Nov 2024 10:11:22 +0100 |
Align the header file with the actual implementation of
this function, as the first argument is source ID and not
notification type.
Signed-off-by: Mauro Carvalho Chehab <mchehab+huawei@kernel.org>
Reviewed-by: Jonathan Cameron <Jonathan.Cameron@huawei.com>
Reviewed-by: Igor Mammedov <imammedo@redhat.com>
---
Changes from v8:
- Non-rename/cleanup changes merged altogether;
- source ID is now more generic, defined per guest target.
That should make easier to add support for 86.
Signed-off-by: Mauro Carvalho Chehab <mchehab+huawei@kernel.org>
---
include/hw/acpi/ghes.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/include/hw/acpi/ghes.h b/include/hw/acpi/ghes.h
index 20016c226d1f..50e3a25ea384 100644
--- a/include/hw/acpi/ghes.h
+++ b/include/hw/acpi/ghes.h
@@ -73,7 +73,7 @@ void acpi_build_hest(GArray *table_data, GArray
*hardware_errors,
const char *oem_id, const char *oem_table_id);
void acpi_ghes_add_fw_cfg(AcpiGhesState *vms, FWCfgState *s,
GArray *hardware_errors);
-int acpi_ghes_record_errors(uint8_t notify, uint64_t error_physical_addr);
+int acpi_ghes_record_errors(uint8_t source_id, uint64_t error_physical_addr);
/**
* acpi_ghes_present: Report whether ACPI GHES table is present
--
2.47.0
- [PATCH v4 15/15] docs: acpi_hest_ghes: fix documentation for CPER size, (continued)
- [PATCH v4 15/15] docs: acpi_hest_ghes: fix documentation for CPER size, Mauro Carvalho Chehab, 2024/11/22
- [PATCH v4 08/15] acpi/ghes: make the GHES record generation more generic, Mauro Carvalho Chehab, 2024/11/22
- [PATCH v4 04/15] acpi/ghes: better handle source_id and notification, Mauro Carvalho Chehab, 2024/11/22
- [PATCH v4 01/15] acpi/ghes: get rid of ACPI_HEST_SRC_ID_RESERVED, Mauro Carvalho Chehab, 2024/11/22
- [PATCH v4 11/15] acpi/ghes: rename etc/hardware_error file macros, Mauro Carvalho Chehab, 2024/11/22
- [PATCH v4 03/15] acpi/ghes: simplify the per-arch caller to build HEST table, Mauro Carvalho Chehab, 2024/11/22
- [PATCH v4 02/15] acpi/ghes: simplify acpi_ghes_record_errors() code, Mauro Carvalho Chehab, 2024/11/22
- [PATCH v4 09/15] acpi/ghes: better name GHES memory error function, Mauro Carvalho Chehab, 2024/11/22
- [PATCH v4 05/15] acpi/ghes: Fix acpi_ghes_record_errors() argument,
Mauro Carvalho Chehab <=