[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH v5 10/16] acpi/ghes: better name GHES memory error function
From: |
Igor Mammedov |
Subject: |
Re: [PATCH v5 10/16] acpi/ghes: better name GHES memory error function |
Date: |
Wed, 4 Dec 2024 17:40:25 +0100 |
On Wed, 4 Dec 2024 08:41:18 +0100
Mauro Carvalho Chehab <mchehab+huawei@kernel.org> wrote:
> The current function used to generate GHES data is specific for
> memory errors. Give a better name for it, as we now have a generic
> function as well.
>
> Reviewed-by: Igor Mammedov <imammedo@redhat.com>
> Reviewed-by: Jonathan Cameron <Jonathan.Cameron@huawei.com>
> Signed-off-by: Mauro Carvalho Chehab <mchehab+huawei@kernel.org>
not that it matters but for FYI
Sign off of author goes 1st and then after it other tags
that were added later
> ---
> hw/acpi/ghes-stub.c | 2 +-
> hw/acpi/ghes.c | 2 +-
> include/hw/acpi/ghes.h | 4 ++--
> target/arm/kvm.c | 2 +-
> 4 files changed, 5 insertions(+), 5 deletions(-)
>
> diff --git a/hw/acpi/ghes-stub.c b/hw/acpi/ghes-stub.c
> index 2b64cbd2819a..7cec1812dad9 100644
> --- a/hw/acpi/ghes-stub.c
> +++ b/hw/acpi/ghes-stub.c
> @@ -11,7 +11,7 @@
> #include "qemu/osdep.h"
> #include "hw/acpi/ghes.h"
>
> -int acpi_ghes_record_errors(uint16_t source_id, uint64_t physical_address)
> +int acpi_ghes_memory_errors(uint16_t source_id, uint64_t physical_address)
> {
> return -1;
> }
> diff --git a/hw/acpi/ghes.c b/hw/acpi/ghes.c
> index 4b5332f8c667..414a4a1ee00e 100644
> --- a/hw/acpi/ghes.c
> +++ b/hw/acpi/ghes.c
> @@ -415,7 +415,7 @@ void ghes_record_cper_errors(const void *cper, size_t len,
> return;
> }
>
> -int acpi_ghes_record_errors(uint16_t source_id, uint64_t physical_address)
> +int acpi_ghes_memory_errors(uint16_t source_id, uint64_t physical_address)
> {
> /* Memory Error Section Type */
> const uint8_t guid[] =
> diff --git a/include/hw/acpi/ghes.h b/include/hw/acpi/ghes.h
> index 8859346af51a..21666a4bcc8b 100644
> --- a/include/hw/acpi/ghes.h
> +++ b/include/hw/acpi/ghes.h
> @@ -74,15 +74,15 @@ void acpi_build_hest(GArray *table_data, GArray
> *hardware_errors,
> const char *oem_id, const char *oem_table_id);
> void acpi_ghes_add_fw_cfg(AcpiGhesState *vms, FWCfgState *s,
> GArray *hardware_errors);
> +int acpi_ghes_memory_errors(uint16_t source_id, uint64_t
> error_physical_addr);
> void ghes_record_cper_errors(const void *cper, size_t len,
> uint16_t source_id, Error **errp);
> -int acpi_ghes_record_errors(uint16_t source_id, uint64_t
> error_physical_addr);
>
> /**
> * acpi_ghes_present: Report whether ACPI GHES table is present
> *
> * Returns: true if the system has an ACPI GHES table and it is
> - * safe to call acpi_ghes_record_errors() to record a memory error.
> + * safe to call acpi_ghes_memory_errors() to record a memory error.
> */
> bool acpi_ghes_present(void);
> #endif
> diff --git a/target/arm/kvm.c b/target/arm/kvm.c
> index 7b6812c0de2e..b4260467f8b9 100644
> --- a/target/arm/kvm.c
> +++ b/target/arm/kvm.c
> @@ -2387,7 +2387,7 @@ void kvm_arch_on_sigbus_vcpu(CPUState *c, int code,
> void *addr)
> */
> if (code == BUS_MCEERR_AR) {
> kvm_cpu_synchronize_state(c);
> - if (!acpi_ghes_record_errors(ACPI_HEST_SRC_ID_SEA, paddr)) {
> + if (!acpi_ghes_memory_errors(ACPI_HEST_SRC_ID_SEA, paddr)) {
> kvm_inject_arm_sea(c);
> } else {
> error_report("failed to record the error");
- [PATCH v5 05/16] acpi/ghes: Fix acpi_ghes_record_errors() argument, (continued)
[PATCH v5 14/16] acpi/ghes: move offset calculus to a separate function, Mauro Carvalho Chehab, 2024/12/04
[PATCH v5 11/16] acpi/ghes: don't crash QEMU if ghes GED is not found, Mauro Carvalho Chehab, 2024/12/04
[PATCH v5 10/16] acpi/ghes: better name GHES memory error function, Mauro Carvalho Chehab, 2024/12/04
- Re: [PATCH v5 10/16] acpi/ghes: better name GHES memory error function,
Igor Mammedov <=
[PATCH v5 06/16] acpi/ghes: Remove a duplicated out of bounds check, Mauro Carvalho Chehab, 2024/12/04
[PATCH v5 08/16] acpi/ghes: don't check if physical_address is not zero, Mauro Carvalho Chehab, 2024/12/04
[PATCH v5 01/16] acpi/ghes: get rid of ACPI_HEST_SRC_ID_RESERVED, Mauro Carvalho Chehab, 2024/12/04
[PATCH v5 16/16] docs: acpi_hest_ghes: fix documentation for CPER size, Mauro Carvalho Chehab, 2024/12/04
[PATCH v5 15/16] acpi/ghes: Change ghes fill logic to work with only one source, Mauro Carvalho Chehab, 2024/12/04
[PATCH v5 12/16] acpi/ghes: rename etc/hardware_error file macros, Mauro Carvalho Chehab, 2024/12/04
[PATCH v5 09/16] acpi/ghes: make the GHES record generation more generic, Mauro Carvalho Chehab, 2024/12/04