qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH v3 02/24] thread-pool: Remove thread_pool_submit() function


From: Maciej S. Szmigiero
Subject: Re: [PATCH v3 02/24] thread-pool: Remove thread_pool_submit() function
Date: Fri, 6 Dec 2024 22:11:59 +0100
User-agent: Mozilla Thunderbird

On 4.12.2024 20:24, Peter Xu wrote:
On Sun, Nov 17, 2024 at 08:19:57PM +0100, Maciej S. Szmigiero wrote:
From: "Maciej S. Szmigiero" <maciej.szmigiero@oracle.com>

This function name conflicts with one used by a future generic thread pool
function and it was only used by one test anyway.

Update the trace event name in thread_pool_submit_aio() accordingly.

Signed-off-by: Maciej S. Szmigiero <maciej.szmigiero@oracle.com>

Reviewed-by: Peter Xu <peterx@redhat.com>

One nitpick:

---
  include/block/thread-pool.h   | 3 +--
  tests/unit/test-thread-pool.c | 2 +-
  util/thread-pool.c            | 7 +------
  util/trace-events             | 2 +-
  4 files changed, 4 insertions(+), 10 deletions(-)

diff --git a/include/block/thread-pool.h b/include/block/thread-pool.h
index 948ff5f30c31..4f6694026123 100644
--- a/include/block/thread-pool.h
+++ b/include/block/thread-pool.h
@@ -30,13 +30,12 @@ ThreadPool *thread_pool_new(struct AioContext *ctx);
  void thread_pool_free(ThreadPool *pool);
/*
- * thread_pool_submit* API: submit I/O requests in the thread's
+ * thread_pool_submit_{aio,co} API: submit I/O requests in the thread's
   * current AioContext.
   */
  BlockAIOCB *thread_pool_submit_aio(ThreadPoolFunc *func, void *arg,
                                     BlockCompletionFunc *cb, void *opaque);
  int coroutine_fn thread_pool_submit_co(ThreadPoolFunc *func, void *arg);
-void thread_pool_submit(ThreadPoolFunc *func, void *arg);
void thread_pool_update_params(ThreadPool *pool, struct AioContext *ctx); diff --git a/tests/unit/test-thread-pool.c b/tests/unit/test-thread-pool.c
index 1483e53473db..7a7055141ddb 100644
--- a/tests/unit/test-thread-pool.c
+++ b/tests/unit/test-thread-pool.c
@@ -46,7 +46,7 @@ static void done_cb(void *opaque, int ret)
  static void test_submit(void)

The test name was still trying to follow the name of API. It can be renamed to test_submit_no_complete()

Ack.

(also the test name str below).


I guess you mean also changing "/thread-pool/submit" to
"/thread-pool/submit_no_complete" in the test main().

Thanks,
Maciej




reply via email to

[Prev in Thread] Current Thread [Next in Thread]