[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v2 4/7] vfio/migration: Rename vfio_devices_all_dirty_tracking()
From: |
Avihai Horon |
Subject: |
[PATCH v2 4/7] vfio/migration: Rename vfio_devices_all_dirty_tracking() |
Date: |
Wed, 18 Dec 2024 15:40:19 +0200 |
vfio_devices_all_dirty_tracking() is used to check if dirty page log
sync is needed. However, besides checking the dirty page tracking
status, it also checks the pre_copy_dirty_page_tracking flag.
Rename it to vfio_devices_log_sync_needed() which reflects its purpose
more accurately and makes the code clearer as there are already several
helpers with similar names.
Signed-off-by: Avihai Horon <avihaih@nvidia.com>
Reviewed-by: Joao Martins <joao.m.martins@oracle.com>
---
hw/vfio/common.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/hw/vfio/common.c b/hw/vfio/common.c
index 2831f674ff..d113d8f4f5 100644
--- a/hw/vfio/common.c
+++ b/hw/vfio/common.c
@@ -191,7 +191,7 @@ bool vfio_devices_all_dirty_tracking_started(
bcontainer->dirty_pages_started;
}
-static bool vfio_devices_all_dirty_tracking(VFIOContainerBase *bcontainer)
+static bool vfio_log_sync_needed(const VFIOContainerBase *bcontainer)
{
VFIODevice *vbasedev;
@@ -1364,7 +1364,7 @@ static void vfio_listener_log_sync(MemoryListener
*listener,
return;
}
- if (vfio_devices_all_dirty_tracking(bcontainer)) {
+ if (vfio_log_sync_needed(bcontainer)) {
ret = vfio_sync_dirty_bitmap(bcontainer, section, &local_err);
if (ret) {
error_report_err(local_err);
--
2.40.1
- [PATCH v2 0/7] migration: Drop/unexport migration_is_device() and migration_is_active(), Avihai Horon, 2024/12/18
- [PATCH v2 4/7] vfio/migration: Rename vfio_devices_all_dirty_tracking(),
Avihai Horon <=
- [PATCH v2 3/7] vfio/migration: Refactor vfio_devices_all_running_and_mig_active() logic, Avihai Horon, 2024/12/18
- [PATCH v2 5/7] system/dirtylimit: Don't use migration_is_active(), Avihai Horon, 2024/12/18
- [PATCH v2 6/7] migration: Drop migration_is_device(), Avihai Horon, 2024/12/18
- [PATCH v2 7/7] migration: Unexport migration_is_active(), Avihai Horon, 2024/12/18
- [PATCH v2 2/7] vfio/migration: Refactor vfio_devices_all_dirty_tracking() logic, Avihai Horon, 2024/12/18
- [PATCH v2 1/7] vfio/container: Add dirty tracking started flag, Avihai Horon, 2024/12/18
- Re: [PATCH v2 0/7] migration: Drop/unexport migration_is_device() and migration_is_active(), Joao Martins, 2024/12/23