[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PULL 00/35] m68k / next-cube patches
From: |
Thomas Huth |
Subject: |
[PULL 00/35] m68k / next-cube patches |
Date: |
Sun, 29 Dec 2024 08:24:51 +0100 |
Hi Stefan!
The following changes since commit 2b7a80e07a29074530a0ebc8005a418ee07b1faf:
Merge tag 'pull-trivial-patches' of https://gitlab.com/mjt0k/qemu into
staging (2024-12-28 10:16:34 -0500)
are available in the Git repository at:
https://gitlab.com/huth/qemu.git tags/pull-request-2024-12-29
for you to fetch changes up to ee58d282aa87a7f4a4409528ff12192c0bcfeb82:
next-cube: add my copyright to the top of the file (2024-12-29 07:13:47 +0100)
----------------------------------------------------------------
* Rework "next-cube" to bring it up-to-date with current coding standards/APIs
* Remove overlapping memory regions of the "next-cube" machine
* Encapsulate the next-cube SCSI related code into a separate device
* QOM-ify the next-rtc device
* Declare m68k devices as big endian instead of native endian
* Disable the CD-ROM drive for the next-cube machine
----------------------------------------------------------------
Mark Cave-Ayland (33):
next-cube: remove 0x14020 dummy value from next_mmio_read()
next-cube: remove overlap between next.dma and next.mmio memory regions
next-cube: create new next.scsi container memory region
next-cube: move next_scsi_init() to next_pc_realize()
next-cube: introduce next_pc_init() object init function
next-cube: introduce next-scsi device
next-cube: move SCSI CSRs from next-pc to the next-scsi device
next-cube: move SCSI 4020/4021 logic from next-pc device to next-scsi
device
next-cube: move floppy disk MMIO to separate memory region in next-pc
next-cube: map ESCC registers as a subregion of the next.scr memory region
next-cube: move ESCC to be QOM child of next-pc device
next-cube: move timer MMIO to separate memory region on next-pc device
next-cube: move en ethernet MMIO to separate memory region on next-pc
device
next-cube: add empty slots for unknown accesses to next.scr memory region
next-cube: remove unused next.scr memory region
next-cube: rearrange NeXTState declarations to improve readability
next-cube: convert next-pc device to use Resettable interface
next-cube: rename typedef struct NextRtc to NeXTRTC
next-cube: use qemu_irq to drive int_status in next_scr2_rtc_update()
next-cube: separate rtc read and write shift logic
next-cube: always use retval to return rtc read values
next-cube: use named gpio to set RTC data bit in scr2
next-cube: use named gpio to read RTC data bit in scr2
next-cube: don't use rtc phase value of -1
next-cube: QOMify NeXTRTC
next-cube: move reset of next-rtc fields from next-pc to next-rtc
next-cube: move rtc-data-in gpio from next-pc to next-rtc device
next-cube: use named gpio output for next-rtc data
next-cube: add rtc-cmd-reset named gpio to reset the rtc state machine
next-cube: add rtc-power-out named gpio to trigger the NEXT_PWR_I
interrupt
next-cube: move next_rtc_cmd_is_write() and next_rtc_data_in_irq()
functions
next-cube: rename old_scr2 and scr2_2 in next_scr2_rtc_update()
next-cube: add my copyright to the top of the file
Philippe Mathieu-Daudé (1):
hw/m68k: Mark devices as big-endian
Thomas Huth (1):
hw/m68k/next-cube: Disable the default CD-ROM drive
hw/m68k/Kconfig | 1 +
hw/m68k/mcf5206.c | 2 +-
hw/m68k/mcf5208.c | 6 +-
hw/m68k/mcf_intc.c | 2 +-
hw/m68k/next-cube.c | 1022 +++++++++++++++++++++++++++++++++------------------
hw/m68k/next-kbd.c | 2 +-
6 files changed, 665 insertions(+), 370 deletions(-)
- [PULL 00/35] m68k / next-cube patches,
Thomas Huth <=
- [PULL 01/35] hw/m68k: Mark devices as big-endian, Thomas Huth, 2024/12/29
- [PULL 03/35] next-cube: remove 0x14020 dummy value from next_mmio_read(), Thomas Huth, 2024/12/29
- [PULL 05/35] next-cube: create new next.scsi container memory region, Thomas Huth, 2024/12/29
- [PULL 02/35] hw/m68k/next-cube: Disable the default CD-ROM drive, Thomas Huth, 2024/12/29
- [PULL 04/35] next-cube: remove overlap between next.dma and next.mmio memory regions, Thomas Huth, 2024/12/29
- [PULL 06/35] next-cube: move next_scsi_init() to next_pc_realize(), Thomas Huth, 2024/12/29
- [PULL 07/35] next-cube: introduce next_pc_init() object init function, Thomas Huth, 2024/12/29
- [PULL 08/35] next-cube: introduce next-scsi device, Thomas Huth, 2024/12/29
- [PULL 09/35] next-cube: move SCSI CSRs from next-pc to the next-scsi device, Thomas Huth, 2024/12/29
- [PULL 10/35] next-cube: move SCSI 4020/4021 logic from next-pc device to next-scsi device, Thomas Huth, 2024/12/29