[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PULL 34/35] next-cube: rename old_scr2 and scr2_2 in next_scr2_rtc_upda
From: |
Thomas Huth |
Subject: |
[PULL 34/35] next-cube: rename old_scr2 and scr2_2 in next_scr2_rtc_update() |
Date: |
Sun, 29 Dec 2024 08:25:25 +0100 |
From: Mark Cave-Ayland <mark.cave-ayland@ilande.co.uk>
Rename them to old_scr2_rtc and scr2_rtc to reflect that they contain the
previous
and current values of the SCR2 RTC bits.
Signed-off-by: Mark Cave-Ayland <mark.cave-ayland@ilande.co.uk>
Reviewed-by: Thomas Huth <huth@tuxfamily.org>
Message-ID: <20241222130012.1013374-33-mark.cave-ayland@ilande.co.uk>
Signed-off-by: Thomas Huth <huth@tuxfamily.org>
---
hw/m68k/next-cube.c | 14 +++++++-------
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/hw/m68k/next-cube.c b/hw/m68k/next-cube.c
index 360a46c32e..513ce5844b 100644
--- a/hw/m68k/next-cube.c
+++ b/hw/m68k/next-cube.c
@@ -177,17 +177,17 @@ static void next_scr2_led_update(NeXTPC *s)
static void next_scr2_rtc_update(NeXTPC *s)
{
- uint8_t old_scr2, scr2_2;
+ uint8_t old_scr2_rtc, scr2_rtc;
- old_scr2 = extract32(s->old_scr2, 8, 8);
- scr2_2 = extract32(s->scr2, 8, 8);
+ old_scr2_rtc = extract32(s->old_scr2, 8, 8);
+ scr2_rtc = extract32(s->scr2, 8, 8);
- if (scr2_2 & 0x1) {
+ if (scr2_rtc & 0x1) {
/* DPRINTF("RTC %x phase %i\n", scr2_2, rtc->phase); */
/* If we are in going down clock... do something */
- if (((old_scr2 & SCR2_RTCLK) != (scr2_2 & SCR2_RTCLK)) &&
- ((scr2_2 & SCR2_RTCLK) == 0)) {
- if (scr2_2 & SCR2_RTDATA) {
+ if (((old_scr2_rtc & SCR2_RTCLK) != (scr2_rtc & SCR2_RTCLK)) &&
+ ((scr2_rtc & SCR2_RTCLK) == 0)) {
+ if (scr2_rtc & SCR2_RTDATA) {
qemu_irq_raise(s->rtc_data_irq);
} else {
qemu_irq_lower(s->rtc_data_irq);
--
2.47.1
- [PULL 24/35] next-cube: use named gpio to set RTC data bit in scr2, (continued)
- [PULL 24/35] next-cube: use named gpio to set RTC data bit in scr2, Thomas Huth, 2024/12/29
- [PULL 30/35] next-cube: use named gpio output for next-rtc data, Thomas Huth, 2024/12/29
- [PULL 26/35] next-cube: don't use rtc phase value of -1, Thomas Huth, 2024/12/29
- [PULL 27/35] next-cube: QOMify NeXTRTC, Thomas Huth, 2024/12/29
- [PULL 29/35] next-cube: move rtc-data-in gpio from next-pc to next-rtc device, Thomas Huth, 2024/12/29
- [PULL 31/35] next-cube: add rtc-cmd-reset named gpio to reset the rtc state machine, Thomas Huth, 2024/12/29
- [PULL 32/35] next-cube: add rtc-power-out named gpio to trigger the NEXT_PWR_I interrupt, Thomas Huth, 2024/12/29
- [PULL 33/35] next-cube: move next_rtc_cmd_is_write() and next_rtc_data_in_irq() functions, Thomas Huth, 2024/12/29
- [PULL 22/35] next-cube: separate rtc read and write shift logic, Thomas Huth, 2024/12/29
- [PULL 35/35] next-cube: add my copyright to the top of the file, Thomas Huth, 2024/12/29
- [PULL 34/35] next-cube: rename old_scr2 and scr2_2 in next_scr2_rtc_update(),
Thomas Huth <=
- [PULL 28/35] next-cube: move reset of next-rtc fields from next-pc to next-rtc, Thomas Huth, 2024/12/29