[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Qemu-ppc] [PATCH 2/3] target-ppc: Use #define instead of opencoding SLB
From: |
Aneesh Kumar K.V |
Subject: |
[Qemu-ppc] [PATCH 2/3] target-ppc: Use #define instead of opencoding SLB valid bit |
Date: |
Mon, 19 Aug 2013 17:59:15 +0530 |
From: "Aneesh Kumar K.V" <address@hidden>
Use SLB_ESID_V instead of (1 << 27) in the code
Signed-off-by: Aneesh Kumar K.V <address@hidden>
---
target-ppc/mmu_helper.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/target-ppc/mmu_helper.c b/target-ppc/mmu_helper.c
index 5dd4e05..9c9132e 100644
--- a/target-ppc/mmu_helper.c
+++ b/target-ppc/mmu_helper.c
@@ -2061,7 +2061,7 @@ void helper_store_sr(CPUPPCState *env, target_ulong
srnum, target_ulong value)
/* ESID = srnum */
rb |= ((uint32_t)srnum & 0xf) << 28;
/* Set the valid bit */
- rb |= 1 << 27;
+ rb |= SLB_ESID_V;
/* Index = ESID */
rb |= (uint32_t)srnum;
--
1.8.1.2