[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH 20/63] pc87312: Rename TYPE_PC87312_SUPERIO to TYPE_PC87312
From: |
Philippe Mathieu-Daudé |
Subject: |
Re: [PATCH 20/63] pc87312: Rename TYPE_PC87312_SUPERIO to TYPE_PC87312 |
Date: |
Thu, 3 Sep 2020 14:45:12 +0200 |
User-agent: |
Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.11.0 |
On 9/3/20 12:42 AM, Eduardo Habkost wrote:
> This will make the type name constant consistent with the name of
> the type checking macro.
>
> Signed-off-by: Eduardo Habkost <ehabkost@redhat.com>
> ---
> Cc: "Hervé Poussineau" <hpoussin@reactos.org>
> Cc: qemu-ppc@nongnu.org
> Cc: qemu-devel@nongnu.org
> ---
> include/hw/isa/pc87312.h | 4 ++--
> hw/isa/pc87312.c | 2 +-
> 2 files changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/include/hw/isa/pc87312.h b/include/hw/isa/pc87312.h
> index a65168a157..da8dc5ddf5 100644
> --- a/include/hw/isa/pc87312.h
> +++ b/include/hw/isa/pc87312.h
> @@ -29,10 +29,10 @@
> #include "qom/object.h"
>
>
> -#define TYPE_PC87312_SUPERIO "pc87312"
> +#define TYPE_PC87312 "pc87312"
We loose self-documentation. What is a TYPE_PC87312
when reviewing a board setup code? Should we add a
comment /* Create the Super I/O */? The current name
is self-describing...
Is it easier to rename the type as 'pc87312-superio'?
#define TYPE_PC87312_SUPERIO "pc87312-superio"
> typedef struct PC87312State PC87312State;
> DECLARE_INSTANCE_CHECKER(PC87312State, PC87312,
> - TYPE_PC87312_SUPERIO)
> + TYPE_PC87312)
>
> struct PC87312State {
> /*< private >*/
> diff --git a/hw/isa/pc87312.c b/hw/isa/pc87312.c
> index 0cacbbc91b..8d7b8d3db2 100644
> --- a/hw/isa/pc87312.c
> +++ b/hw/isa/pc87312.c
> @@ -371,7 +371,7 @@ static void pc87312_class_init(ObjectClass *klass, void
> *data)
> }
>
> static const TypeInfo pc87312_type_info = {
> - .name = TYPE_PC87312_SUPERIO,
> + .name = TYPE_PC87312,
> .parent = TYPE_ISA_SUPERIO,
> .instance_size = sizeof(PC87312State),
> .instance_init = pc87312_initfn,
>