[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v6 21/25] ppc4xx_sdram: Use hwaddr for memory bank size
From: |
BALATON Zoltan |
Subject: |
[PATCH v6 21/25] ppc4xx_sdram: Use hwaddr for memory bank size |
Date: |
Sat, 24 Sep 2022 14:28:11 +0200 (CEST) |
This resolves the target_ulong dependency that's clearly wrong and was
also noted in a fixme comment.
Signed-off-by: BALATON Zoltan <balaton@eik.bme.hu>
Reviewed-by: Philippe Mathieu-Daudé <f4bug@amsat.org>
---
hw/ppc/ppc4xx_sdram.c | 14 ++++----------
1 file changed, 4 insertions(+), 10 deletions(-)
diff --git a/hw/ppc/ppc4xx_sdram.c b/hw/ppc/ppc4xx_sdram.c
index 48f099a4dc..be319ecd02 100644
--- a/hw/ppc/ppc4xx_sdram.c
+++ b/hw/ppc/ppc4xx_sdram.c
@@ -34,7 +34,6 @@
#include "qapi/error.h"
#include "qemu/log.h"
#include "exec/address-spaces.h" /* get_system_memory() */
-#include "exec/cpu-defs.h" /* target_ulong */
#include "hw/irq.h"
#include "hw/qdev-properties.h"
#include "hw/ppc/ppc4xx.h"
@@ -126,11 +125,6 @@ enum {
/*****************************************************************************/
/* DDR SDRAM controller */
-/*
- * XXX: TOFIX: some patches have made this code become inconsistent:
- * there are type inconsistencies, mixing hwaddr, target_ulong
- * and uint32_t
- */
static uint32_t sdram_ddr_bcr(hwaddr ram_base, hwaddr ram_size)
{
uint32_t bcr;
@@ -174,9 +168,9 @@ static inline hwaddr sdram_ddr_base(uint32_t bcr)
return bcr & 0xFF800000;
}
-static target_ulong sdram_ddr_size(uint32_t bcr)
+static hwaddr sdram_ddr_size(uint32_t bcr)
{
- target_ulong size;
+ hwaddr size;
int sh;
sh = (bcr >> 17) & 0x7;
@@ -523,9 +517,9 @@ static inline hwaddr sdram_ddr2_base(uint32_t bcr)
return (bcr & 0xffe00000) << 2;
}
-static uint64_t sdram_ddr2_size(uint32_t bcr)
+static hwaddr sdram_ddr2_size(uint32_t bcr)
{
- uint64_t size;
+ hwaddr size;
int sh;
sh = 1024 - ((bcr >> 6) & 0x3ff);
--
2.30.4
- Re: [PATCH v6 14/25] ppc440_sdram: Move RAM size check to ppc440_sdram_init, (continued)
- [PATCH v6 22/25] ppc4xx_sdram: Rename local state variable for brevity, BALATON Zoltan, 2022/09/24
- [PATCH v6 12/25] ppc440_sdram: Rename local variable for readability, BALATON Zoltan, 2022/09/24
- [PATCH v6 10/25] ppc440_sdram: Implement enable bit in the DDR2 SDRAM controller, BALATON Zoltan, 2022/09/24
- [PATCH v6 17/25] ppc440_uc.c: Remove unneeded parenthesis, BALATON Zoltan, 2022/09/24
- [PATCH v6 19/25] ppc4xx_devs.c: Move DDR SDRAM controller model to ppc4xx_sdram.c, BALATON Zoltan, 2022/09/24
- [PATCH v6 13/25] ppc4xx_sdram: Rename functions to prevent name clashes, BALATON Zoltan, 2022/09/24
- [PATCH v6 18/25] ppc440_uc.c: Move DDR2 SDRAM controller model to ppc4xx_sdram.c, BALATON Zoltan, 2022/09/24
- [PATCH v6 21/25] ppc4xx_sdram: Use hwaddr for memory bank size,
BALATON Zoltan <=
- [PATCH v6 20/25] ppc4xx_sdram: Move ppc4xx_sdram_banks() to ppc4xx_sdram.c, BALATON Zoltan, 2022/09/24
- [PATCH v6 23/25] ppc4xx_sdram: Generalise bank setup, BALATON Zoltan, 2022/09/24
- [PATCH v6 24/25] ppc4xx_sdram: Convert DDR SDRAM controller to new bank handling, BALATON Zoltan, 2022/09/24
- [PATCH v6 25/25] ppc4xx_sdram: Add errp parameter to ppc4xx_sdram_banks(), BALATON Zoltan, 2022/09/24
- Re: [PATCH v6 00/25] ppc4xx_sdram QOMify and clean ups, Daniel Henrique Barboza, 2022/09/26
- Re: [PATCH v6 00/25] ppc4xx_sdram QOMify and clean ups, Cédric Le Goater, 2022/09/26