|
From: | BALATON Zoltan |
Subject: | Re: [PATCH 2/6] target/ppc: optimize hreg_compute_pmu_hflags_value |
Date: | Mon, 20 May 2024 13:26:16 +0200 (CEST) |
On Mon, 20 May 2024, Harsh Prateek Bora wrote:
Cache env->spr[SPR_POWER_MMCR0] in a local variable as used in multiple conditions to avoid multiple indirect accesses. Signed-off-by: Harsh Prateek Bora <harshpb@linux.ibm.com> --- target/ppc/helper_regs.c | 9 +++++---- 1 file changed, 5 insertions(+), 4 deletions(-) diff --git a/target/ppc/helper_regs.c b/target/ppc/helper_regs.c index 945fa1a596..5de0df5795 100644 --- a/target/ppc/helper_regs.c +++ b/target/ppc/helper_regs.c @@ -50,15 +50,16 @@ void hreg_swap_gpr_tgpr(CPUPPCState *env) static uint32_t hreg_compute_pmu_hflags_value(CPUPPCState *env) { uint32_t hflags = 0; - #if defined(TARGET_PPC64) - if (env->spr[SPR_POWER_MMCR0] & MMCR0_PMCC0) { + target_ulong spr_power_mmcr0 = env->spr[SPR_POWER_MMCR0];
I think this is simple enough so the compiler should be able to find out on its own but adding a local is also simple and may make it more readable but I'd call it just mmcr0 for readability.
Regards, BALATON Zoltan
+ + if (spr_power_mmcr0 & MMCR0_PMCC0) { hflags |= 1 << HFLAGS_PMCC0; } - if (env->spr[SPR_POWER_MMCR0] & MMCR0_PMCC1) { + if (spr_power_mmcr0 & MMCR0_PMCC1) { hflags |= 1 << HFLAGS_PMCC1; } - if (env->spr[SPR_POWER_MMCR0] & MMCR0_PMCjCE) { + if (spr_power_mmcr0 & MMCR0_PMCjCE) { hflags |= 1 << HFLAGS_PMCJCE; }
[Prev in Thread] | Current Thread | [Next in Thread] |