[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH 19/24] gdbstub: Avoid including 'cpu.h' in 'gdbstub/helpers.h'
From: |
Philippe Mathieu-Daudé |
Subject: |
[PATCH 19/24] gdbstub: Avoid including 'cpu.h' in 'gdbstub/helpers.h' |
Date: |
Thu, 18 Apr 2024 21:25:18 +0200 |
We only need the "exec/tswap.h" and "cpu-param.h" headers.
Only include "cpu.h" in the target gdbstub.c source files.
Signed-off-by: Philippe Mathieu-Daudé <philmd@linaro.org>
---
include/gdbstub/helpers.h | 3 ++-
target/avr/gdbstub.c | 1 +
target/tricore/gdbstub.c | 1 +
3 files changed, 4 insertions(+), 1 deletion(-)
diff --git a/include/gdbstub/helpers.h b/include/gdbstub/helpers.h
index 6277a858a1..26140ef1ac 100644
--- a/include/gdbstub/helpers.h
+++ b/include/gdbstub/helpers.h
@@ -16,7 +16,8 @@
#error "gdbstub helpers should only be included by target specific code"
#endif
-#include "cpu.h"
+#include "exec/tswap.h"
+#include "cpu-param.h"
/*
* The GDB remote protocol transfers values in target byte order. As
diff --git a/target/avr/gdbstub.c b/target/avr/gdbstub.c
index 2eeee2bf4e..d6d3c1479b 100644
--- a/target/avr/gdbstub.c
+++ b/target/avr/gdbstub.c
@@ -20,6 +20,7 @@
#include "qemu/osdep.h"
#include "gdbstub/helpers.h"
+#include "cpu.h"
int avr_cpu_gdb_read_register(CPUState *cs, GByteArray *mem_buf, int n)
{
diff --git a/target/tricore/gdbstub.c b/target/tricore/gdbstub.c
index f9309c5e27..29a70051ff 100644
--- a/target/tricore/gdbstub.c
+++ b/target/tricore/gdbstub.c
@@ -19,6 +19,7 @@
#include "qemu/osdep.h"
#include "gdbstub/helpers.h"
+#include "cpu.h"
#define LCX_REGNUM 32
--
2.41.0
- Re: [PATCH 10/24] exec: Reduce tlb_set_dirty() declaration scope, (continued)
- [PATCH 11/24] exec: Move tlb_reset_dirty*() declarations to 'exec/cputlb.h', Philippe Mathieu-Daudé, 2024/04/18
- [PATCH 12/24] exec: Move CPUTLBEntry helpers to cputlb.c, Philippe Mathieu-Daudé, 2024/04/18
- [PATCH 14/24] exec: Rename 'exec/user/guest-base.h' as 'user/guest-base.h', Philippe Mathieu-Daudé, 2024/04/18
- [PATCH 15/24] exec: Restrict inclusion of 'user/guest-base.h', Philippe Mathieu-Daudé, 2024/04/18
- [PATCH 19/24] gdbstub: Avoid including 'cpu.h' in 'gdbstub/helpers.h',
Philippe Mathieu-Daudé <=
- [PATCH 21/24] plugins: Un-inline qemu_plugin_disable_mem_helpers(), Philippe Mathieu-Daudé, 2024/04/18
- [PATCH 23/24] exec: Remove 'disas/disas.h' from 'exec/log.h', Philippe Mathieu-Daudé, 2024/04/18
- [PATCH 13/24] target/sparc: Replace abi_ulong by uint32_t for TARGET_ABI32, Philippe Mathieu-Daudé, 2024/04/18
- [PATCH 16/24] exec: Move GUEST_ADDR_MAX definition to 'cpu_ldst.h', Philippe Mathieu-Daudé, 2024/04/18
- [PATCH 18/24] plugins: Include missing 'qemu/bitmap.h' header, Philippe Mathieu-Daudé, 2024/04/18