[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v2 07/19] qapi/machine: Drop temporary 'prefix'
From: |
Markus Armbruster |
Subject: |
[PATCH v2 07/19] qapi/machine: Drop temporary 'prefix' |
Date: |
Wed, 4 Sep 2024 13:18:24 +0200 |
Recent commit "qapi: Smarter camel_to_upper() to reduce need for
'prefix'" added a temporary 'prefix' to delay changing the generated
code.
Revert it. This improves HmatLBDataType's generated enumeration
constant prefix from HMATLB_DATA_TYPE to HMAT_LB_DATA_TYPE, and
HmatLBMemoryHierarchy's from HMATLB_MEMORY_HIERARCHY to
HMAT_LB_MEMORY_HIERARCHY.
Signed-off-by: Markus Armbruster <armbru@redhat.com>
Reviewed-by: Zhao Liu <zhao1.liu@intel.com>
---
qapi/machine.json | 2 --
hw/core/numa.c | 4 ++--
hw/pci-bridge/cxl_upstream.c | 4 ++--
3 files changed, 4 insertions(+), 6 deletions(-)
diff --git a/qapi/machine.json b/qapi/machine.json
index 552d1c20e9..d4317435e7 100644
--- a/qapi/machine.json
+++ b/qapi/machine.json
@@ -686,7 +686,6 @@
# Since: 5.0
##
{ 'enum': 'HmatLBMemoryHierarchy',
- 'prefix': 'HMATLB_MEMORY_HIERARCHY', # TODO drop
'data': [ 'memory', 'first-level', 'second-level', 'third-level' ] }
##
@@ -713,7 +712,6 @@
# Since: 5.0
##
{ 'enum': 'HmatLBDataType',
- 'prefix': 'HMATLB_DATA_TYPE', # TODO drop
'data': [ 'access-latency', 'read-latency', 'write-latency',
'access-bandwidth', 'read-bandwidth', 'write-bandwidth' ] }
diff --git a/hw/core/numa.c b/hw/core/numa.c
index f8ce332cfe..fb81c1ed51 100644
--- a/hw/core/numa.c
+++ b/hw/core/numa.c
@@ -249,7 +249,7 @@ void parse_numa_hmat_lb(NumaState *numa_state,
NumaHmatLBOptions *node,
lb_data.initiator = node->initiator;
lb_data.target = node->target;
- if (node->data_type <= HMATLB_DATA_TYPE_WRITE_LATENCY) {
+ if (node->data_type <= HMAT_LB_DATA_TYPE_WRITE_LATENCY) {
/* Input latency data */
if (!node->has_latency) {
@@ -313,7 +313,7 @@ void parse_numa_hmat_lb(NumaState *numa_state,
NumaHmatLBOptions *node,
numa_info[node->target].lb_info_provided |= BIT(0);
}
lb_data.data = node->latency;
- } else if (node->data_type >= HMATLB_DATA_TYPE_ACCESS_BANDWIDTH) {
+ } else if (node->data_type >= HMAT_LB_DATA_TYPE_ACCESS_BANDWIDTH) {
/* Input bandwidth data */
if (!node->has_bandwidth) {
error_setg(errp, "Missing 'bandwidth' option");
diff --git a/hw/pci-bridge/cxl_upstream.c b/hw/pci-bridge/cxl_upstream.c
index e51221a5f3..f3e46f0651 100644
--- a/hw/pci-bridge/cxl_upstream.c
+++ b/hw/pci-bridge/cxl_upstream.c
@@ -234,7 +234,7 @@ static int build_cdat_table(CDATSubHeader ***cdat_table,
void *priv)
.type = CDAT_TYPE_SSLBIS,
.length = sslbis_size,
},
- .data_type = HMATLB_DATA_TYPE_ACCESS_LATENCY,
+ .data_type = HMAT_LB_DATA_TYPE_ACCESS_LATENCY,
.entry_base_unit = 10000,
},
};
@@ -254,7 +254,7 @@ static int build_cdat_table(CDATSubHeader ***cdat_table,
void *priv)
.type = CDAT_TYPE_SSLBIS,
.length = sslbis_size,
},
- .data_type = HMATLB_DATA_TYPE_ACCESS_BANDWIDTH,
+ .data_type = HMAT_LB_DATA_TYPE_ACCESS_BANDWIDTH,
.entry_base_unit = 1024,
},
};
--
2.46.0
- [PATCH v2 11/19] qapi/crypto: Rename QCryptoHashAlgorithm to *Algo, and drop prefix, (continued)
[PATCH v2 04/19] qapi/common: Drop temporary 'prefix', Markus Armbruster, 2024/09/04
[PATCH v2 12/19] qapi/crypto: Rename QCryptoCipherAlgorithm to *Algo, and drop prefix, Markus Armbruster, 2024/09/04
[PATCH v2 07/19] qapi/machine: Drop temporary 'prefix',
Markus Armbruster <=