classpath-patches
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [cp-patches] move native method from SelectorImpl to VMSelector


From: Michael Koch
Subject: Re: [cp-patches] move native method from SelectorImpl to VMSelector
Date: Thu, 22 Jul 2004 09:28:53 +0200
User-agent: KMail/1.6.2

Am Donnerstag, 22. Juli 2004 00:33 schrieb Patrik Reali:
> Hi!
>
> A patch proposal for moving a native method from
> gnu/java/nio/SelectorImpl to vm/reference/gnu/java/nio/VMSelector
> and the subsequent changes in jni.
>
> Any comments or complaints?

-                result = implSelect (read, write, except, timeout);
+                result = VMSelector.implSelect (read, write, except, 
timeout);

You can rename "VMSelector.implSelect" to "VMSelector.select". New 
need to distinguish this method to others in the VMSelector class.

-$(top_srcdir)/include/gnu_java_nio_SelectorImpl.h: 
$(top_srcdir)/gnu/java/nio/SelectorImpl.java
-       $(JAVAH) -o $@ gnu.java.nio.SelectorImpl
+$(top_srcdir)/include/gnu_java_nio_VMSelector.h: 
$(top_srcdir)/gnu/java/nio/VMSelector.java
+       $(JAVAH) -o $@ gnu.java.nio.VMSelector

This breaks because VMSelector.java will be in 
"../vm/current/gnu/java/nio/VMSelector.java"


Just my two cents,
Michael




reply via email to

[Prev in Thread] Current Thread [Next in Thread]