classpath-patches
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [cp-patches] move native method from SelectorImpl to VMSelector


From: Patrik Reali
Subject: Re: [cp-patches] move native method from SelectorImpl to VMSelector
Date: Sun, 25 Jul 2004 15:13:28 +0200

Argh! Always the same mistake.

Thank you very much for cross-checking.

-Patrik

--On Donnerstag, 22. Juli 2004 09:28 +0200 Michael Koch <address@hidden> wrote:

Am Donnerstag, 22. Juli 2004 00:33 schrieb Patrik Reali:
Hi!

A patch proposal for moving a native method from
gnu/java/nio/SelectorImpl to vm/reference/gnu/java/nio/VMSelector
and the subsequent changes in jni.

Any comments or complaints?

-                result = implSelect (read, write, except, timeout);
+                result = VMSelector.implSelect (read, write, except,
timeout);

You can rename "VMSelector.implSelect" to "VMSelector.select". New
need to distinguish this method to others in the VMSelector class.

-$(top_srcdir)/include/gnu_java_nio_SelectorImpl.h:
$(top_srcdir)/gnu/java/nio/SelectorImpl.java
-       $(JAVAH) -o $@ gnu.java.nio.SelectorImpl
+$(top_srcdir)/include/gnu_java_nio_VMSelector.h:
$(top_srcdir)/gnu/java/nio/VMSelector.java
+       $(JAVAH) -o $@ gnu.java.nio.VMSelector

This breaks because VMSelector.java will be in
"../vm/current/gnu/java/nio/VMSelector.java"


Just my two cents,
Michael






reply via email to

[Prev in Thread] Current Thread [Next in Thread]