emacs-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: SVG support(again) ?


From: Richard Stallman
Subject: Re: SVG support(again) ?
Date: Sat, 18 Aug 2007 20:45:13 -0400

You're getting closer.  There are enough comments now,
but they need to be formatted cleanly and consistently with the
rest of Emacs.

    /* DEF_IMGLIB_FN() here in the future.

Do you mean

    /* TO DO: use DEF_IMGLIB_FN here.

It is vital to use words like "TO DO:" and "use",
because following such patterns makes the meaning clear.

(In GNU we don't write `()' after a function name.)

Aside from that, it will be clean if you fill the comment lines
to 70 character width.

Also, please use two spaces at the end of a sentence,
and please put a period and two spaces at the end of every comment
that contents sentences.

    /* Load SVG image IMG for use on frame F.  Value is non-zero if
       successful. this function wil go into the svg_type structure, and
       the prototype thus needs to be compatible with that structure */

should be

    /* Load SVG image IMG for use on frame F.  Value is non-zero if
       successful.  This function will go into the svg_type structure, and
       the prototype, so it needs to be compatible with that structure.  */


          contents = slurp_file (SDATA (file), &size); /* read the entire file 
into memory*/

That style makes lines wide and hard to read, so please put the comment
on a separate line.  It should start with a capital letter, and end
with a period and two spaces.

          /* Read the entire file into memory.  */
          contents = slurp_file (SDATA (file), &size);


    /* helper function for svg_load, does the actual loading
     given contents and size, apart from frame and image structures, passed 
from svg_load

     Uses librsvg to do most of the image processing.

     Returns non-zero when sucessful
    */

This should explain each of the arguments by name.
Please also start it with a capital letter, and end it with a period,
and avoid lines that are too long.




reply via email to

[Prev in Thread] Current Thread [Next in Thread]