emacs-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: special_mtime


From: Troels Nielsen
Subject: Re: special_mtime
Date: Wed, 4 Jul 2012 21:45:17 +0200

On Wed, Jul 4, 2012 at 7:12 PM, Paul Eggert <address@hidden> wrote:
> On 07/04/2012 08:51 AM, Eli Zaretskii wrote:
>> How about a better name that somehow hints at what the function does,
>
> Thanks for catching that.  I changed it to time_error_value.
> If you think of a better name please feel free to change it again.
>

Hi Paul

+/* Return a special mtime value indicating the error number ERRNUM.  */
+static EMACS_TIME
+special_mtime (int errnum)
+{
+  EMACS_TIME t;
+  int ns = (errno == ENOENT || errno == EACCES || errno == ENOTDIR
+           ? NONEXISTENT_MODTIME_NSECS
+           : UNKNOWN_MODTIME_NSECS);
+  EMACS_SET_SECS_NSECS (t, 0, ns);
+  return t;
+}

Shouldn't errno be errnum here?

Regards
Troels Nielsen



reply via email to

[Prev in Thread] Current Thread [Next in Thread]