lilypond-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Allows for automatic renumbering of measure numbers at volta repeats


From: address@hidden
Subject: Re: Allows for automatic renumbering of measure numbers at volta repeats. (issue 5440049)
Date: Wed, 30 Nov 2011 10:14:04 +0100

On Nov 30, 2011, at 6:29 AM, address@hidden wrote:

> Now it looks quite good, and still works great.
> C'est si bon.
> Is maith é sin.
> Smashing, old chap.
> 
> 

Thanks!

> 
> http://codereview.appspot.com/5440049/diff/11010/lily/bar-number-engraver.cc
> File lily/bar-number-engraver.cc (right):
> 
> http://codereview.appspot.com/5440049/diff/11010/lily/bar-number-engraver.cc#newcode68
> lily/bar-number-engraver.cc:68: if we're starting an alternative, we set
> the starting
> if we're starting the first alternative,

Fixed.

> 
> http://codereview.appspot.com/5440049/diff/11010/lily/bar-number-engraver.cc#newcode128
> lily/bar-number-engraver.cc:128: for (int i = 0; i < alternative_number_
> / 26; i++)
> I don't think you want to loop.  It gives
> a b c ... z aa ab .. az ba bb .. bz cca ccb ... fffffa fffffb
> 

Fixed.

> http://codereview.appspot.com/5440049/diff/11010/lily/bar-number-engraver.cc#newcode129
> lily/bar-number-engraver.cc:129: text_tag += alphabet.at
> (alternative_number_ / 26);
> best to do a modulo 26, so that a sticky key typo does not cause a
> segfault.
> \repeat volta 888
> 

Fixed.

> http://codereview.appspot.com/5440049/diff/11010/scm/define-music-callbacks.scm
> File scm/define-music-callbacks.scm (right):
> 
> http://codereview.appspot.com/5440049/diff/11010/scm/define-music-callbacks.scm#newcode45
> scm/define-music-callbacks.scm:45: (append
> ;; set properties for proper bar numbering
> 

Fixed.

> http://codereview.appspot.com/5440049/diff/11010/scm/define-music-callbacks.scm#newcode50
> scm/define-music-callbacks.scm:50: 'alternative-increment
> Alternatively, you could ask Volta_repeat_iterator::next_element() to
> set this for you when it sets the text for the little number under the
> volta bracket.
> 

Mm...I'm tempted to keep it the way it is, just cuz it's easier to read all of 
the properties having to do with the creation of the event in the same place 
(in this case, the elements callback).

Cheers,
MS

> http://codereview.appspot.com/5440049/




reply via email to

[Prev in Thread] Current Thread [Next in Thread]