qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 03/10] coroutine: rename qemu_co_queue_next_bh()


From: Paolo Bonzini
Subject: Re: [Qemu-devel] [PATCH 03/10] coroutine: rename qemu_co_queue_next_bh() to qemu_co_process_runnable()
Date: Tue, 03 Apr 2012 13:31:00 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:11.0) Gecko/20120329 Thunderbird/11.0.1

Il 03/04/2012 10:38, Lai Jiangshan ha scritto:
> Signed-off-by: Lai Jiangshan <address@hidden>
> ---
>  qemu-coroutine-lock.c |    6 +++---
>  trace-events          |    2 +-
>  2 files changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/qemu-coroutine-lock.c b/qemu-coroutine-lock.c
> index 10e8dbb..90141cd 100644
> --- a/qemu-coroutine-lock.c
> +++ b/qemu-coroutine-lock.c
> @@ -33,11 +33,11 @@ static QTAILQ_HEAD(, Coroutine) co_runnable_queue =
>      QTAILQ_HEAD_INITIALIZER(co_runnable_queue);
>  static QEMUBH* co_runnable_bh;
>  
> -static void qemu_co_queue_next_bh(void *opaque)
> +static void qemu_co_process_runnable(void *opaque)
>  {
>      Coroutine *next;
>  
> -    trace_qemu_co_queue_next_bh();
> +    trace_qemu_co_process_runnable();
>      while ((next = QTAILQ_FIRST(&co_runnable_queue))) {
>          QTAILQ_REMOVE(&co_runnable_queue, next, co_queue_next);
>          qemu_coroutine_enter(next, NULL);
> @@ -49,7 +49,7 @@ void qemu_co_queue_init(CoQueue *queue)
>      QTAILQ_INIT(&queue->entries);
>  
>      if (!co_runnable_bh) {
> -        co_runnable_bh = qemu_bh_new(qemu_co_queue_next_bh, NULL);
> +        co_runnable_bh = qemu_bh_new(qemu_co_process_runnable, NULL);
>      }
>  }
>  
> diff --git a/trace-events b/trace-events
> index 70f059d..a1737c2 100644
> --- a/trace-events
> +++ b/trace-events
> @@ -561,7 +561,7 @@ qemu_coroutine_yield(void *from, void *to) "from %p to %p"
>  qemu_coroutine_terminate(void *co) "self %p"
>  
>  # qemu-coroutine-lock.c
> -qemu_co_queue_next_bh(void) ""
> +qemu_co_process_runnable(void) ""
>  qemu_co_queue_next(void *next) "next %p"
>  qemu_co_mutex_lock_entry(void *mutex, void *self) "mutex %p self %p"
>  qemu_co_mutex_lock_return(void *mutex, void *self) "mutex %p self %p"

Reviewed-by: Paolo Bonzini <address@hidden>



reply via email to

[Prev in Thread] Current Thread [Next in Thread]