qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PULL v2 00/41] QAPI patches for 2017-06-09


From: no-reply
Subject: Re: [Qemu-devel] [PULL v2 00/41] QAPI patches for 2017-06-09
Date: Tue, 20 Jun 2017 08:38:34 -0700 (PDT)

Hi,

This series seems to have some coding style problems. See output below for
more information:

Type: series
Message-id: address@hidden
Subject: [Qemu-devel] [PULL v2 00/41] QAPI patches for 2017-06-09

=== TEST SCRIPT BEGIN ===
#!/bin/bash

BASE=base
n=1
total=$(git log --oneline $BASE.. | wc -l)
failed=0

git config --local diff.renamelimit 0
git config --local diff.renames True

commits="$(git log --format=%H --reverse $BASE..)"
for c in $commits; do
    echo "Checking PATCH $n/$total: $(git log -n 1 --format=%s $c)..."
    if ! git show $c --format=email | ./scripts/checkpatch.pl --mailback -; then
        failed=1
        echo
    fi
    n=$((n+1))
done

exit $failed
=== TEST SCRIPT END ===

Updating 3c8cf5a9c21ff8782164d1def7f44bd888713384
Switched to a new branch 'test'
a4e8dac tests/qdict: check more get_try_int() cases
f19e899 console: use get_uint() for "head" property
c23cbd5 i386/cpu: use get_uint() for "min-level"/"min-xlevel" properties
ee6c66c numa: use get_uint() for "size" property
fc06041 pnv-core: use get_uint() for "core-pir" property
56d8304 pvpanic: use get_uint() for "ioport" property
64ae787 auxbus: use get_uint() for "addr" property
c125082 arm: use get_uint() for "mp-affinity" property
83a3433 xen: use get_uint() for "max-ram-below-4g" property
7e3b57d pc: use get_uint() for "hpet-intcap" property
c2e6cf3 pc: use get_uint() for "apic-id" property
8453cc9 pc: use get_uint() for "iobase" property
0676b98 acpi: use get_uint() for "pci-hole*" properties
2d0badd acpi: use get_uint() for various acpi properties
93b3df9 acpi: use get_uint() for "acpi-pcihp-io*" properties
6625c7c platform-bus: use get_uint() for "addr" property
96d6aba bcm2835_fb: use {get, set}_uint() for "vcram-size" and "vcram-base"
d107f50 aspeed: use {set, get}_uint() for "ram-size" property
3d8b453 pcihp: use get_uint() for "bsel" property
e61ff60 pc-dimm: make "size" property uint64
25fce56 pc-dimm: use get_uint() for dimm properties
35641f6 isa: use get_uint() for "io-base"
53fb92e qdev: Use appropriate getter/setters type
fc9a390 apic-common: make "id" property a uint32
58b5fe1 qdev: avoid type casts between signed and unsigned
b2a3cbf qdev: wrap default property value in an union
46b185b qdev: Rename DEFINE_PROP_DEFAULT() to DEFINE_PROP_SIGNED()
efded0d object: use more specific property type names
e13f177 q35: fix get_mmcfg_size to use uint64 visitor
c20018f object: add uint property setter/getter
ded896a qapi: update the qobject visitor to use QNUM_U64
ef6ccb0 json: learn to parse uint64 numbers
ef5a970 qnum: add uint type
71c4589 tests: remove /{qnum, qlist, dict}/destroy test
3d17cba qapi: Remove visit_start_alternate() parameter promote_int
7f96333 qapi: merge QInt and QFloat in QNum
22c66a1 qapi: Clean up qobject_input_type_number() control flow
224785d tests: add more int/number ranges checks
6ee38b3 tests: Remove test cases for alternates of 'number' and 'int'
b23e9b3 object: fix potential leak in getters
4632090 qdev: remove PropertyInfo.qtype field

=== OUTPUT BEGIN ===
Checking PATCH 1/41: qdev: remove PropertyInfo.qtype field...
Checking PATCH 2/41: object: fix potential leak in getters...
Checking PATCH 3/41: tests: Remove test cases for alternates of 'number' and 
'int'...
Checking PATCH 4/41: tests: add more int/number ranges checks...
Checking PATCH 5/41: qapi: Clean up qobject_input_type_number() control flow...
Checking PATCH 6/41: qapi: merge QInt and QFloat in QNum...
ERROR: do not use C99 // comments
#1975: FILE: tests/check-qnum.c:39:
+    // destroy doesn't exit yet

ERROR: do not use C99 // comments
#1991: FILE: tests/check-qnum.c:55:
+    // destroy doesn't exit yet

total: 2 errors, 0 warnings, 1894 lines checked

Your patch has style problems, please review.  If any of these errors
are false positives report them to the maintainer, see
CHECKPATCH in MAINTAINERS.

Checking PATCH 7/41: qapi: Remove visit_start_alternate() parameter 
promote_int...
Checking PATCH 8/41: tests: remove /{qnum, qlist, dict}/destroy test...
Checking PATCH 9/41: qnum: add uint type...
Checking PATCH 10/41: json: learn to parse uint64 numbers...
Checking PATCH 11/41: qapi: update the qobject visitor to use QNUM_U64...
Checking PATCH 12/41: object: add uint property setter/getter...
Checking PATCH 13/41: q35: fix get_mmcfg_size to use uint64 visitor...
Checking PATCH 14/41: object: use more specific property type names...
Checking PATCH 15/41: qdev: Rename DEFINE_PROP_DEFAULT() to 
DEFINE_PROP_SIGNED()...
Checking PATCH 16/41: qdev: wrap default property value in an union...
Checking PATCH 17/41: qdev: avoid type casts between signed and unsigned...
Checking PATCH 18/41: apic-common: make "id" property a uint32...
Checking PATCH 19/41: qdev: Use appropriate getter/setters type...
Checking PATCH 20/41: isa: use get_uint() for "io-base"...
Checking PATCH 21/41: pc-dimm: use get_uint() for dimm properties...
Checking PATCH 22/41: pc-dimm: make "size" property uint64...
Checking PATCH 23/41: pcihp: use get_uint() for "bsel" property...
Checking PATCH 24/41: aspeed: use {set, get}_uint() for "ram-size" property...
Checking PATCH 25/41: bcm2835_fb: use {get, set}_uint() for "vcram-size" and 
"vcram-base"...
Checking PATCH 26/41: platform-bus: use get_uint() for "addr" property...
Checking PATCH 27/41: acpi: use get_uint() for "acpi-pcihp-io*" properties...
Checking PATCH 28/41: acpi: use get_uint() for various acpi properties...
Checking PATCH 29/41: acpi: use get_uint() for "pci-hole*" properties...
Checking PATCH 30/41: pc: use get_uint() for "iobase" property...
Checking PATCH 31/41: pc: use get_uint() for "apic-id" property...
Checking PATCH 32/41: pc: use get_uint() for "hpet-intcap" property...
Checking PATCH 33/41: xen: use get_uint() for "max-ram-below-4g" property...
Checking PATCH 34/41: arm: use get_uint() for "mp-affinity" property...
Checking PATCH 35/41: auxbus: use get_uint() for "addr" property...
Checking PATCH 36/41: pvpanic: use get_uint() for "ioport" property...
Checking PATCH 37/41: pnv-core: use get_uint() for "core-pir" property...
Checking PATCH 38/41: numa: use get_uint() for "size" property...
Checking PATCH 39/41: i386/cpu: use get_uint() for "min-level"/"min-xlevel" 
properties...
Checking PATCH 40/41: console: use get_uint() for "head" property...
Checking PATCH 41/41: tests/qdict: check more get_try_int() cases...
=== OUTPUT END ===

Test command exited with code: 1


---
Email generated automatically by Patchew [http://patchew.org/].
Please send your feedback to address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]