[Top][All Lists]
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH 6/7] Increase BPB size to accommodate FAT32.
From: |
Pavel Roskin |
Subject: |
[PATCH 6/7] Increase BPB size to accommodate FAT32. |
Date: |
Tue, 14 Jul 2009 21:00:49 -0400 |
User-agent: |
StGit/0.15-rc1-4-g4ce8 |
ChangeLog:
* include/grub/i386/pc/boot.h (GRUB_BOOT_MACHINE_BPB_END):
Increase to 0x5a. Adjust other offsets accordingly.
Original patch by Yves Blusseau <address@hidden>
---
include/grub/i386/pc/boot.h | 8 ++++----
1 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/include/grub/i386/pc/boot.h b/include/grub/i386/pc/boot.h
index a91f55a..cf73c3a 100644
--- a/include/grub/i386/pc/boot.h
+++ b/include/grub/i386/pc/boot.h
@@ -26,16 +26,16 @@
#define GRUB_BOOT_MACHINE_BPB_START 0x3
/* The offset of the end of BPB (BIOS Parameter Block). */
-#define GRUB_BOOT_MACHINE_BPB_END 0x3e
+#define GRUB_BOOT_MACHINE_BPB_END 0x5a
/* The offset of KERNEL_SECTOR. */
-#define GRUB_BOOT_MACHINE_KERNEL_SECTOR 0x44
+#define GRUB_BOOT_MACHINE_KERNEL_SECTOR 0x5a
/* The offset of BOOT_DRIVE. */
-#define GRUB_BOOT_MACHINE_BOOT_DRIVE 0x4c
+#define GRUB_BOOT_MACHINE_BOOT_DRIVE 0x62
/* The offset of BOOT_DRIVE_CHECK. */
-#define GRUB_BOOT_MACHINE_DRIVE_CHECK 0x4e
+#define GRUB_BOOT_MACHINE_DRIVE_CHECK 0x64
/* The offset of a magic number used by Windows NT. */
#define GRUB_BOOT_MACHINE_WINDOWS_NT_MAGIC 0x1b8
- [PATCH 1/7] Make boot/i386/pc/boot.S safer to modify, Pavel Roskin, 2009/07/14
- [PATCH 2/7] Remove unused version information from boot/i386/pc/boot.S, Pavel Roskin, 2009/07/14
- [PATCH 3/7] Eliminate kernel_segment, Pavel Roskin, 2009/07/14
- [PATCH 4/7] Eliminate kernel_address, Pavel Roskin, 2009/07/14
- [PATCH 5/7] Add newline after "Error" in bootsector, Pavel Roskin, 2009/07/14
- [PATCH 6/7] Increase BPB size to accommodate FAT32.,
Pavel Roskin <=
- [PATCH 7/7] RFC: Use correct addresses, eliminate manual relocations, Pavel Roskin, 2009/07/14
- Re: [PATCH 7/7] RFC: Use correct addresses, eliminate manual relocations, Pavel Roskin, 2009/07/15
- Re: [PATCH 7/7] RFC: Use correct addresses, eliminate manual relocations, Vladimir 'phcoder' Serbinenko, 2009/07/15
- Re: [PATCH 7/7] RFC: Use correct addresses, eliminate manual relocations, Pavel Roskin, 2009/07/15
- Re: [PATCH 7/7] RFC: Use correct addresses, eliminate manual relocations, Pavel Roskin, 2009/07/15
- Re: [PATCH 7/7] RFC: Use correct addresses, eliminate manual relocations, Vladimir 'phcoder' Serbinenko, 2009/07/16
Re: [PATCH 1/7] Make boot/i386/pc/boot.S safer to modify, Robert Millan, 2009/07/16