[Top][All Lists]
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Monotone-devel] turning execute attribute on
From: |
Derek Scherger |
Subject: |
Re: [Monotone-devel] turning execute attribute on |
Date: |
Tue, 17 Jul 2007 22:28:29 -0600 |
User-agent: |
Thunderbird 2.0.0.4 (X11/20070619) |
Brian May wrote:
>>>>>> "Nathaniel" == Nathaniel Smith <address@hidden> writes:
>
> Nathaniel> On Tue, Jul 17, 2007 at 10:35:48AM +1000, Brian May wrote:
> >> address@hidden:~/tree/config$ mtn set modules/global/bin/fsh
> >> mtn:execute true mtn: misuse: error converting 22 UTF-8 bytes
> >> to IDNA ACE: non-LDH characters
>
> Nathaniel> You mean 'attr set'.
>
> Nathaniel> UI fixes welcome.
>
> Thanks. Typo :-(.
>
> However I am still confused with that message... What is a non-LDH
> character?
Letter/Digit/Hyphen
Apparently database var names are restricted to this subset of valid
characters.
In terms of the UI's two different types of set commands, I wonder if
the database variable commands should be bona-fide db or var subcommands
rather than top level commands?
We have these commands for attrs:
attr set PATH ATTR VALUE
attr get PATH [ATTR]
attr drop PATH [ATTR]
and these for vars:
set DOMAIN NAME VALUE
unset DOMAIN NAME
ls vars [DOMAIN]
Perhaps the var commands would be more consistent as:
var set DOMAIN NAME VALUE
var get [DOMAIN [NAME]]
var drop DOMAIN [NAME]
However,
- I wonder whether "drop" should be "remove" or something more
bitwise get/set-ish like "clear"
- bare "var get" seems a bit odd... perhaps "var list" would be better
but then we'd be inconsistent unless we had "attr list" which isn't
so bad but then should probably be list attrs to fit in with the
current list commands which themselves need help
- drop DOMAIN (with no specific variable seems a bit prone to foot
shooting
- looking at the list commands there are a few things that might be
better as varous subcommands
Consider the key commands
passphrase
genkey
dropkey
privkey
pubkey
read
ls keys
Perhaps a set of key subcommands would be better
key passphrase
key create
key remove
key dump
key load
key list
A few different commands like these and branch/tag/cert/etc. may fall
into a basic create/remove/list pattern with some specific variations. I
wonder if we could get rid of a bunch of the different list commands and
perhaps only use list for paths (known/unknown/ignored/missing/...) or
maybe get rid of list entirely?
Cheers,
Derek