|
From: | Richard Henderson |
Subject: | Re: [PATCH 3/7] target/i386: Use tcg_gen_ext_tl |
Date: | Sat, 21 Oct 2023 18:29:26 -0700 |
User-agent: | Mozilla Thunderbird |
On 10/21/23 00:59, Paolo Bonzini wrote:
On 10/19/23 23:57, Philippe Mathieu-Daudé wrote:On 19/10/23 20:29, Richard Henderson wrote:- default: + if (memop_size(size) == TARGET_LONG_BITS) { return src; }Any opinions about adding something like this on top? ------------------------- 8< ------------------------------- From: Paolo Bonzini <pbonzini@redhat.com> Subject: [PATCH] include, target/i386: define and use MO_TL
Yes, that looks fine.
static TCGv gen_ext_tl(TCGv dst, TCGv src, MemOp size, bool sign) { - if (memop_size(size) == TARGET_LONG_BITS) { + if (size == MO_TL) {
Yep.
I can add it in my x86 series if desirable ...
That's probably fine; you may well get your PR in before my next.
+ tcg_gen_ext_tl(dst, src, size | (sign ? MO_SIGN : 0)); + return dst; }While here, I'd rename 'size' -> 'mop'. Regardless,Not sure about that, because "size" should be just the low bits of MemOp (the MO_SIGN bit is passed separately).
Agreed. r~
[Prev in Thread] | Current Thread | [Next in Thread] |