> static TCGv gen_ext_tl(TCGv dst, TCGv src, MemOp size, bool sign)
> {
> - if (memop_size(size) == TARGET_LONG_BITS) {
> + if (size == MO_TL) {
Yep.
> I can add it in my x86 series if desirable ...
That's probably fine; you may well get your PR in before my next.
I will probably keep only SHA instructions for 8.2 (plus the VEX todos and the reorganized checks) and delay the rest.
There are a bunch of things I would do in a slightly different manner now, so it's better to clean up the generic x86 decoder code before implementing the less orthogonal instruction formats from the one-byte. I should have time to finish opcodes 0xC0 to 0xFF over the Christmas break in time for 9.0. :)
Paolo
>>> + tcg_gen_ext_tl(dst, src, size | (sign ? MO_SIGN : 0));
>>> + return dst;
>>> }
>>
>> While here, I'd rename 'size' -> 'mop'. Regardless,
>
> Not sure about that, because "size" should be just the low bits of MemOp (the MO_SIGN bit
> is passed separately).
Agreed.
r~