qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH v4 07/16] hw/i386: Rename apicid_from_topo_ids to x86_apicid_


From: Igor Mammedov
Subject: Re: [PATCH v4 07/16] hw/i386: Rename apicid_from_topo_ids to x86_apicid_from_topo_ids
Date: Thu, 20 Feb 2020 13:43:24 +0100

On Thu, 13 Feb 2020 12:17:12 -0600
Babu Moger <address@hidden> wrote:

> For consistancy rename apicid_from_topo_ids to x86_apicid_from_topo_ids.
> No functional change.
> 
> Signed-off-by: Babu Moger <address@hidden>

Reviewed-by: Igor Mammedov <address@hidden>

> ---
>  hw/i386/pc.c               |    2 +-
>  include/hw/i386/topology.h |    6 +++---
>  2 files changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/hw/i386/pc.c b/hw/i386/pc.c
> index 02fdb3d506..be72a49716 100644
> --- a/hw/i386/pc.c
> +++ b/hw/i386/pc.c
> @@ -1808,7 +1808,7 @@ static void pc_cpu_pre_plug(HotplugHandler *hotplug_dev,
>          topo_ids.die_id = cpu->die_id;
>          topo_ids.core_id = cpu->core_id;
>          topo_ids.smt_id = cpu->thread_id;
> -        cpu->apic_id = apicid_from_topo_ids(&topo_info, &topo_ids);
> +        cpu->apic_id = x86_apicid_from_topo_ids(&topo_info, &topo_ids);
>      }
>  
>      cpu_slot = pc_find_cpu_slot(MACHINE(pcms), cpu->apic_id, &idx);
> diff --git a/include/hw/i386/topology.h b/include/hw/i386/topology.h
> index 522c77e6a9..3158157430 100644
> --- a/include/hw/i386/topology.h
> +++ b/include/hw/i386/topology.h
> @@ -107,8 +107,8 @@ static inline unsigned apicid_pkg_offset(X86CPUTopoInfo 
> *topo_info)
>   *
>   * The caller must make sure core_id < nr_cores and smt_id < nr_threads.
>   */
> -static inline apic_id_t apicid_from_topo_ids(X86CPUTopoInfo *topo_info,
> -                                             const X86CPUTopoIDs *topo_ids)
> +static inline apic_id_t x86_apicid_from_topo_ids(X86CPUTopoInfo *topo_info,
> +                                                 const X86CPUTopoIDs 
> *topo_ids)
>  {
>      return (topo_ids->pkg_id  << apicid_pkg_offset(topo_info)) |
>             (topo_ids->die_id  << apicid_die_offset(topo_info)) |
> @@ -160,7 +160,7 @@ static inline apic_id_t 
> x86_apicid_from_cpu_idx(X86CPUTopoInfo *topo_info,
>  {
>      X86CPUTopoIDs topo_ids;
>      x86_topo_ids_from_idx(topo_info, cpu_index, &topo_ids);
> -    return apicid_from_topo_ids(topo_info, &topo_ids);
> +    return x86_apicid_from_topo_ids(topo_info, &topo_ids);
>  }
>  
>  #endif /* HW_I386_TOPOLOGY_H */
> 




reply via email to

[Prev in Thread] Current Thread [Next in Thread]