[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH v6 03/12] hmp: Set cur_mon only in handle_hmp_command()
From: |
Markus Armbruster |
Subject: |
Re: [PATCH v6 03/12] hmp: Set cur_mon only in handle_hmp_command() |
Date: |
Tue, 04 Aug 2020 14:54:05 +0200 |
User-agent: |
Gnus/5.13 (Gnus v5.13) Emacs/26.3 (gnu/linux) |
Kevin Wolf <kwolf@redhat.com> writes:
> cur_mon is updated relatively early in the command handling code even
@cur_mon doesn't exist anymore (you renamed it to @cur_monitor in the
previous patch). Either say "The current monitor", or use the actual
variable name.
> though only the command handler actually needs it. Move it to
> handle_hmp_command().
The commit message explains why moving it isn't wrong. Can you also
explain why you want to move it?
>
> Signed-off-by: Kevin Wolf <kwolf@redhat.com>
> ---
> monitor/hmp.c | 23 ++++++++++++-----------
> monitor/misc.c | 7 -------
> 2 files changed, 12 insertions(+), 18 deletions(-)
>
> diff --git a/monitor/hmp.c b/monitor/hmp.c
> index f609fcf75b..79be6f26de 100644
> --- a/monitor/hmp.c
> +++ b/monitor/hmp.c
> @@ -1061,6 +1061,7 @@ void handle_hmp_command(MonitorHMP *mon, const char
> *cmdline)
> QDict *qdict;
> const HMPCommand *cmd;
> const char *cmd_start = cmdline;
> + Monitor *old_mon;
>
> trace_handle_hmp_command(mon, cmdline);
>
> @@ -1079,7 +1080,12 @@ void handle_hmp_command(MonitorHMP *mon, const char
> *cmdline)
> return;
> }
>
> + /* old_mon is non-NULL when called from qmp_human_monitor_command() */
> + old_mon = monitor_cur();
> + monitor_set_cur(&mon->common);
> cmd->cmd(&mon->common, qdict);
> + monitor_set_cur(old_mon);
> +
> qobject_unref(qdict);
> }
>
> @@ -1300,26 +1306,21 @@ cleanup:
>
> static void monitor_read(void *opaque, const uint8_t *buf, int size)
> {
> - MonitorHMP *mon;
> - Monitor *old_mon = monitor_cur();
> + Monitor *mon = opaque;
> + MonitorHMP *hmp_mon = container_of(mon, MonitorHMP, common);
> int i;
>
> - monitor_set_cur(opaque);
> - mon = container_of(monitor_cur(), MonitorHMP, common);
> -
> - if (mon->rs) {
> + if (hmp_mon->rs) {
> for (i = 0; i < size; i++) {
> - readline_handle_byte(mon->rs, buf[i]);
> + readline_handle_byte(hmp_mon->rs, buf[i]);
> }
> } else {
> if (size == 0 || buf[size - 1] != 0) {
> - monitor_printf(&mon->common, "corrupted command\n");
> + monitor_printf(mon, "corrupted command\n");
> } else {
> - handle_hmp_command(mon, (char *)buf);
> + handle_hmp_command(hmp_mon, (char *)buf);
> }
> }
> -
> - monitor_set_cur(old_mon);
> }
This does a bit more than just move monitor_set_cur(). Okay.
>
> static void monitor_event(void *opaque, QEMUChrEvent event)
> diff --git a/monitor/misc.c b/monitor/misc.c
> index 6cf7f60872..e0ab265726 100644
> --- a/monitor/misc.c
> +++ b/monitor/misc.c
> @@ -121,18 +121,13 @@ char *qmp_human_monitor_command(const char
> *command_line, bool has_cpu_index,
> int64_t cpu_index, Error **errp)
> {
> char *output = NULL;
> - Monitor *old_mon;
> MonitorHMP hmp = {};
>
> monitor_data_init(&hmp.common, false, true, false);
>
> - old_mon = monitor_cur();
> - monitor_set_cur(&hmp.common);
> -
> if (has_cpu_index) {
> int ret = monitor_set_cpu(&hmp.common, cpu_index);
> if (ret < 0) {
> - monitor_set_cur(old_mon);
> error_setg(errp, QERR_INVALID_PARAMETER_VALUE, "cpu-index",
> "a CPU number");
> goto out;
> @@ -140,7 +135,6 @@ char *qmp_human_monitor_command(const char *command_line,
> bool has_cpu_index,
> }
>
> handle_hmp_command(&hmp, command_line);
> - monitor_set_cur(old_mon);
>
> qemu_mutex_lock(&hmp.common.mon_lock);
> if (qstring_get_length(hmp.common.outbuf) > 0) {
> @@ -258,7 +252,6 @@ static void monitor_init_qmp_commands(void)
> /* Set the current CPU defined by the user. Callers must hold BQL. */
> int monitor_set_cpu(Monitor *mon, int cpu_index)
> {
> - Monitor *cur_mon = monitor_cur();
> CPUState *cpu;
>
> cpu = qemu_get_cpu(cpu_index);
[Prev in Thread] |
Current Thread |
[Next in Thread] |
- Re: [PATCH v6 03/12] hmp: Set cur_mon only in handle_hmp_command(),
Markus Armbruster <=