[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH for-5.2 v2 9/9] tests/qtest/cdrom: Add more s390x-related boo
From: |
Cornelia Huck |
Subject: |
Re: [PATCH for-5.2 v2 9/9] tests/qtest/cdrom: Add more s390x-related boot tests |
Date: |
Thu, 6 Aug 2020 13:23:44 +0200 |
On Thu, 6 Aug 2020 12:53:49 +0200
Thomas Huth <thuth@redhat.com> wrote:
> Let's add two new tests:
>
> 1) Booting with "bootindex" is the architected default behavior on the
> s390x target, so we should have at least one test that is using the
> "bootindex" property.
>
> 2) The s390-ccw bios used to fail when other unbootable devices have
> been specified before the bootable device (without "bootindex"). Now
> that the s390-ccw bios is a little bit smarter here, we should test
> this scenario, too, to avoid regressions.
>
> Signed-off-by: Thomas Huth <thuth@redhat.com>
> ---
> tests/qtest/cdrom-test.c | 12 ++++++++++++
> 1 file changed, 12 insertions(+)
>
> diff --git a/tests/qtest/cdrom-test.c b/tests/qtest/cdrom-test.c
> index 833a0508a1..13e22f57c1 100644
> --- a/tests/qtest/cdrom-test.c
> +++ b/tests/qtest/cdrom-test.c
> @@ -163,6 +163,18 @@ static void add_s390x_tests(void)
> qtest_add_data_func("cdrom/boot/virtio-scsi",
> "-device virtio-scsi -device scsi-cd,drive=cdr "
> "-blockdev file,node-name=cdr,filename=",
> test_cdboot);
> + qtest_add_data_func("cdrom/boot/with-bootindex",
> + "-device virtio-serial -device virtio-scsi "
> + "-device virtio-blk,drive=d1 "
> + "-drive driver=null-co,read-zeroes=on,if=none,id=d1 "
> + "-device virtio-blk,drive=d2,bootindex=1 "
> + "-drive if=none,id=d2,media=cdrom,file=",
> test_cdboot);
> + qtest_add_data_func("cdrom/boot/without-bootindex",
> + "-device virtio-scsi -device virtio-serial "
> + "-device x-terminal3270 -device virtio-blk,drive=d1 "
Any special reason for that 3270 device here? Or just to add more
variety? :)
> + "-drive driver=null-co,read-zeroes=on,if=none,id=d1 "
> + "-device virtio-blk,drive=d2 "
> + "-drive if=none,id=d2,media=cdrom,file=",
> test_cdboot);
> }
>
> int main(int argc, char **argv)
- [PATCH for-5.2 v2 4/9] pc-bios/s390-ccw: Move the inner logic of find_subch() to a separate function, (continued)
- [PATCH for-5.2 v2 4/9] pc-bios/s390-ccw: Move the inner logic of find_subch() to a separate function, Thomas Huth, 2020/08/06
- [PATCH for-5.2 v2 5/9] pc-bios/s390-ccw: Do not bail out early if not finding a SCSI disk, Thomas Huth, 2020/08/06
- [PATCH for-5.2 v2 6/9] pc-bios/s390-ccw: Scan through all devices if no boot device specified, Thomas Huth, 2020/08/06
- [PATCH for-5.2 v2 7/9] pc-bios/s390-ccw: Allow booting in case the first virtio-blk disk is bad, Thomas Huth, 2020/08/06
- [PATCH for-5.2 v2 8/9] pc-bios/s390-ccw/main: Remove superfluous call to enable_subchannel(), Thomas Huth, 2020/08/06
- [PATCH for-5.2 v2 9/9] tests/qtest/cdrom: Add more s390x-related boot tests, Thomas Huth, 2020/08/06
- Re: [PATCH for-5.2 v2 9/9] tests/qtest/cdrom: Add more s390x-related boot tests,
Cornelia Huck <=
- Re: [PATCH for-5.2 v2 9/9] tests/qtest/cdrom: Add more s390x-related boot tests, Janosch Frank, 2020/08/06