[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PULL 00/23] SD/MMC patches for 2020-08-21
From: |
Philippe Mathieu-Daudé |
Subject: |
[PULL 00/23] SD/MMC patches for 2020-08-21 |
Date: |
Fri, 21 Aug 2020 19:28:53 +0200 |
The following changes since commit d6f83a72a7db94a3ede9f5cc4fb39f9c8e89f954:
Merge remote-tracking branch 'remotes/philmd-gitlab/tags/acceptance-testing=
-20200812' into staging (2020-08-21 14:51:43 +0100)
are available in the Git repository at:
https://gitlab.com/philmd/qemu.git tags/sd-next-20200821
for you to fetch changes up to 6d2d4069c47e23b9e3913f9c8204fd0edcb99fb3:
hw/sd: Correct the maximum size of a Standard Capacity SD Memory Card (2020=
-08-21 16:49:22 +0200)
----------------------------------------------------------------
SD/MMC patches
- Convert legacy SD host controller to the SDBus API
- Move legacy API to a separate "sdcard_legacy.h" header
- Introduce methods to access multiple bytes on SDBus data lines
- Fix 'switch function' group location
- Fix SDSC maximum card size (2GB)
CI jobs result:
https://gitlab.com/philmd/qemu/-/pipelines/180605963
----------------------------------------------------------------
Alistair Francis (1):
hw/sd/pl181: Replace fprintf(stderr, "*\n") with error_report()
Bin Meng (2):
hw/sd: Fix incorrect populated function switch status data structure
hw/sd: Correct the maximum size of a Standard Capacity SD Memory Card
Philippe Mathieu-Daud=C3=A9 (20):
hw/sd/pxa2xx_mmci: Do not create SD card within the SD host controller
hw/sd/pxa2xx_mmci: Trivial simplification
hw/lm32/milkymist: Un-inline milkymist_memcard_create()
hw/sd/milkymist: Create the SDBus at init()
hw/sd/milkymist: Do not create SD card within the SD host controller
hw/sd/pl181: Rename pl181_send_command() as pl181_do_command()
hw/sd/pl181: Add TODO to use Fifo32 API
hw/sd/pl181: Use named GPIOs
hw/sd/pl181: Expose a SDBus and connect the SDCard to it
hw/sd/pl181: Do not create SD card within the SD host controller
hw/sd/pl181: Replace disabled fprintf()s by trace events
hw/sd/sdcard: Make sd_data_ready() static
hw/sd: Move sdcard legacy API to 'hw/sd/sdcard_legacy.h'
hw/sd: Rename read/write_data() as read/write_byte()
hw/sd: Rename sdbus_write_data() as sdbus_write_byte()
hw/sd: Rename sdbus_read_data() as sdbus_read_byte()
hw/sd: Add sdbus_write_data() to write multiples bytes on the data
line
hw/sd: Use sdbus_write_data() instead of sdbus_write_byte when
possible
hw/sd: Add sdbus_read_data() to read multiples bytes on the data line
hw/sd: Use sdbus_read_data() instead of sdbus_read_byte() when
possible
hw/lm32/milkymist-hw.h | 11 ----
include/hw/arm/pxa.h | 3 +-
include/hw/sd/sd.h | 73 +++++++++++++++-------
include/hw/sd/sdcard_legacy.h | 50 +++++++++++++++
hw/arm/integratorcp.c | 17 +++++-
hw/arm/pxa2xx.c | 39 +++++++++---
hw/arm/realview.c | 16 ++++-
hw/arm/versatilepb.c | 26 +++++++-
hw/arm/vexpress.c | 15 ++++-
hw/lm32/milkymist.c | 24 ++++++++
hw/sd/allwinner-sdhost.c | 24 +++-----
hw/sd/bcm2835_sdhost.c | 4 +-
hw/sd/core.c | 38 ++++++++++--
hw/sd/milkymist-memcard.c | 71 ++++++++++++----------
hw/sd/omap_mmc.c | 10 +--
hw/sd/pl181.c | 111 +++++++++++++++++++---------------
hw/sd/pxa2xx_mmci.c | 19 ++----
hw/sd/sd.c | 28 +++++----
hw/sd/sdhci.c | 46 ++++----------
hw/sd/ssi-sd.c | 2 +-
hw/sd/trace-events | 10 +++
21 files changed, 415 insertions(+), 222 deletions(-)
create mode 100644 include/hw/sd/sdcard_legacy.h
--=20
2.26.2
- [PULL 00/23] SD/MMC patches for 2020-08-21,
Philippe Mathieu-Daudé <=
- [PULL 01/23] hw/sd/pxa2xx_mmci: Do not create SD card within the SD host controller, Philippe Mathieu-Daudé, 2020/08/21
- [PULL 02/23] hw/sd/pxa2xx_mmci: Trivial simplification, Philippe Mathieu-Daudé, 2020/08/21
- [PULL 03/23] hw/lm32/milkymist: Un-inline milkymist_memcard_create(), Philippe Mathieu-Daudé, 2020/08/21
- [PULL 04/23] hw/sd/milkymist: Create the SDBus at init(), Philippe Mathieu-Daudé, 2020/08/21
- [PULL 05/23] hw/sd/milkymist: Do not create SD card within the SD host controller, Philippe Mathieu-Daudé, 2020/08/21
- [PULL 06/23] hw/sd/pl181: Replace fprintf(stderr, "*\n") with error_report(), Philippe Mathieu-Daudé, 2020/08/21
- [PULL 07/23] hw/sd/pl181: Rename pl181_send_command() as pl181_do_command(), Philippe Mathieu-Daudé, 2020/08/21
- [PULL 08/23] hw/sd/pl181: Add TODO to use Fifo32 API, Philippe Mathieu-Daudé, 2020/08/21
- [PULL 09/23] hw/sd/pl181: Use named GPIOs, Philippe Mathieu-Daudé, 2020/08/21
- [PULL 11/23] hw/sd/pl181: Do not create SD card within the SD host controller, Philippe Mathieu-Daudé, 2020/08/21