[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH v5 09/13] hw/pci-host/gpex-acpi: Use acpi_uid property.
From: |
Igor Mammedov |
Subject: |
Re: [PATCH v5 09/13] hw/pci-host/gpex-acpi: Use acpi_uid property. |
Date: |
Mon, 15 Jul 2024 16:29:41 +0200 |
On Fri, 12 Jul 2024 12:08:13 +0100
Jonathan Cameron <Jonathan.Cameron@huawei.com> wrote:
> Reduce the direct use of PCI internals inside ACPI table creation.
>
> Suggested-by: Igor Mammedov <imammedo@redhat.com>
> Tested-by: "Huang, Ying" <ying.huang@intel.com>
> Signed-off-by: Jonathan Cameron <Jonathan.Cameron@huawei.com>
Reviewed-by: Igor Mammedov <imammedo@redhat.com>
> ---
> v5: Similar to previous, use bus number, not uid in ACPI device naming so
> that uid can be 32 bits and we don't need checks to ensure it is only
> 8 bits. Not change to the actual numbers as the UID == bus_num
> ---
> hw/pci-host/gpex-acpi.c | 5 ++++-
> 1 file changed, 4 insertions(+), 1 deletion(-)
>
> diff --git a/hw/pci-host/gpex-acpi.c b/hw/pci-host/gpex-acpi.c
> index f69413ea2c..f271817ef5 100644
> --- a/hw/pci-host/gpex-acpi.c
> +++ b/hw/pci-host/gpex-acpi.c
> @@ -140,6 +140,7 @@ void acpi_dsdt_add_gpex(Aml *scope, struct GPEXConfig
> *cfg)
> QLIST_FOREACH(bus, &bus->child, sibling) {
> uint8_t bus_num = pci_bus_num(bus);
> uint8_t numa_node = pci_bus_numa_node(bus);
> + uint32_t uid;
> bool is_cxl = pci_bus_is_cxl(bus);
>
> if (!pci_bus_is_root(bus)) {
> @@ -155,6 +156,8 @@ void acpi_dsdt_add_gpex(Aml *scope, struct GPEXConfig
> *cfg)
> nr_pcie_buses = bus_num;
> }
>
> + uid = object_property_get_uint(OBJECT(bus), "acpi_uid",
> + &error_fatal);
> dev = aml_device("PC%.02X", bus_num);
> if (is_cxl) {
> struct Aml *pkg = aml_package(2);
> @@ -167,7 +170,7 @@ void acpi_dsdt_add_gpex(Aml *scope, struct GPEXConfig
> *cfg)
> aml_append(dev, aml_name_decl("_CID",
> aml_string("PNP0A03")));
> }
> aml_append(dev, aml_name_decl("_BBN", aml_int(bus_num)));
> - aml_append(dev, aml_name_decl("_UID", aml_int(bus_num)));
> + aml_append(dev, aml_name_decl("_UID", aml_int(uid)));
> aml_append(dev, aml_name_decl("_STR", aml_unicode("pxb
> Device")));
> aml_append(dev, aml_name_decl("_CCA", aml_int(1)));
> if (numa_node != NUMA_NODE_UNASSIGNED) {
- [PATCH v5 04/13] hw/acpi: Rename build_all_acpi_generic_initiators() to build_acpi_generic_initiator(), (continued)
- [PATCH v5 04/13] hw/acpi: Rename build_all_acpi_generic_initiators() to build_acpi_generic_initiator(), Jonathan Cameron, 2024/07/12
- [PATCH v5 05/13] hw/pci: Add a busnr property to pci_props and use for acpi/gi, Jonathan Cameron, 2024/07/12
- [PATCH v5 06/13] acpi/pci: Move Generic Initiator object handling into acpi/pci.*, Jonathan Cameron, 2024/07/12
- [PATCH v5 07/13] hw/pci-bridge: Add acpi_uid property to TYPE_PXB_BUS, Jonathan Cameron, 2024/07/12
- [PATCH v5 08/13] hw/i386/acpi: Use TYPE_PXB_BUS property acpi_uid for DSDT, Jonathan Cameron, 2024/07/12
- [PATCH v5 09/13] hw/pci-host/gpex-acpi: Use acpi_uid property., Jonathan Cameron, 2024/07/12
- Re: [PATCH v5 09/13] hw/pci-host/gpex-acpi: Use acpi_uid property.,
Igor Mammedov <=
- [PATCH v5 10/13] hw/acpi: Generic Port Affinity Structure support, Jonathan Cameron, 2024/07/12
[PATCH v5 11/13] bios-tables-test: Allow for new acpihmat-generic-x test data., Jonathan Cameron, 2024/07/12
[PATCH v5 12/13] bios-tables-test: Add complex SRAT / HMAT test for GI GP, Jonathan Cameron, 2024/07/12
[PATCH v5 13/13] bios-tables-test: Add data for complex numa test (GI, GP etc), Jonathan Cameron, 2024/07/12