[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PULL 08/27] hw: Rename DeviceClass::reset field to legacy_reset
From: |
Peter Maydell |
Subject: |
[PULL 08/27] hw: Rename DeviceClass::reset field to legacy_reset |
Date: |
Fri, 13 Sep 2024 16:13:52 +0100 |
Rename the DeviceClass::reset field to legacy_reset; this is helpful
both in flagging up that it's best not used in new code and in
making it easy to search for where it's being used still.
Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
Reviewed-by: Philippe Mathieu-Daudé <philmd@linaro.org>
Reviewed-by: Richard Henderson <richard.henderson@linaro.org>
Message-id: 20240830145812.1967042-9-peter.maydell@linaro.org
---
include/hw/qdev-core.h | 4 ++--
hw/core/qdev.c | 8 ++++----
2 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/include/hw/qdev-core.h b/include/hw/qdev-core.h
index ade85c31e05..aa97c34a4be 100644
--- a/include/hw/qdev-core.h
+++ b/include/hw/qdev-core.h
@@ -152,14 +152,14 @@ struct DeviceClass {
/* callbacks */
/**
- * @reset: deprecated device reset method pointer
+ * @legacy_reset: deprecated device reset method pointer
*
* Modern code should use the ResettableClass interface to
* implement a multi-phase reset.
*
* TODO: remove once every reset callback is unused
*/
- DeviceReset reset;
+ DeviceReset legacy_reset;
DeviceRealize realize;
DeviceUnrealize unrealize;
diff --git a/hw/core/qdev.c b/hw/core/qdev.c
index 17423a9f573..460114609b0 100644
--- a/hw/core/qdev.c
+++ b/hw/core/qdev.c
@@ -776,8 +776,8 @@ static void device_transitional_reset(Object *obj)
* devices) or a device's specific method for not-yet transitioned devices.
* In both case, it does not reset children.
*/
- if (dc->reset) {
- dc->reset(DEVICE(obj));
+ if (dc->legacy_reset) {
+ dc->legacy_reset(DEVICE(obj));
}
}
@@ -788,7 +788,7 @@ static void device_transitional_reset(Object *obj)
static ResettableTrFunction device_get_transitional_reset(Object *obj)
{
DeviceClass *dc = DEVICE_GET_CLASS(obj);
- if (dc->reset != device_phases_reset) {
+ if (dc->legacy_reset != device_phases_reset) {
/*
* dc->reset has been overridden by a subclass,
* the device is not ready for multi phase yet.
@@ -846,7 +846,7 @@ static void device_class_init(ObjectClass *class, void
*data)
void device_class_set_legacy_reset(DeviceClass *dc, DeviceReset dev_reset)
{
- dc->reset = dev_reset;
+ dc->legacy_reset = dev_reset;
}
void device_class_set_parent_realize(DeviceClass *dc,
--
2.34.1
- [PULL 02/27] hw/s390/virtio-ccw: Convert to three-phase reset, (continued)
- [PULL 02/27] hw/s390/virtio-ccw: Convert to three-phase reset, Peter Maydell, 2024/09/13
- [PULL 03/27] target/s390: Convert CPU to Resettable interface, Peter Maydell, 2024/09/13
- [PULL 09/27] hw: Remove device_phases_reset(), Peter Maydell, 2024/09/13
- [PULL 13/27] hw/boards: Add hvf_get_physical_address_range to MachineClass, Peter Maydell, 2024/09/13
- [PULL 06/27] hw: Define new device_class_set_legacy_reset(), Peter Maydell, 2024/09/13
- [PULL 21/27] hw/net/can/xlnx-versal-canfd: Fix byte ordering, Peter Maydell, 2024/09/13
- [PULL 24/27] MAINTAINERS: Remove Vikram Garhwal as maintainer, Peter Maydell, 2024/09/13
- [PULL 25/27] MAINTAINERS: Update Xilinx Versal OSPI maintainer's email address, Peter Maydell, 2024/09/13
- [PULL 17/27] hw/net/can/xlnx-versal-canfd: Fix interrupt level, Peter Maydell, 2024/09/13
- [PULL 16/27] target/arm/tcg: refine cache descriptions with a wrapper, Peter Maydell, 2024/09/13
- [PULL 08/27] hw: Rename DeviceClass::reset field to legacy_reset,
Peter Maydell <=
- [PULL 23/27] hw/net/can/xlnx-versal-canfd: Fix FIFO issues, Peter Maydell, 2024/09/13
- [PULL 20/27] hw/net/can/xlnx-versal-canfd: Handle flags correctly, Peter Maydell, 2024/09/13
- [PULL 10/27] hw/core/qdev: Simplify legacy_reset handling, Peter Maydell, 2024/09/13
- [PULL 12/27] kvm: Use 'unsigned long' for request argument in functions wrapping ioctl(), Peter Maydell, 2024/09/13
- [PULL 18/27] hw/net/can/xlnx-versal-canfd: Fix CAN FD flag check, Peter Maydell, 2024/09/13
- [PULL 22/27] hw/net/can/xlnx-versal-canfd: Simplify DLC conversions, Peter Maydell, 2024/09/13
- [PULL 27/27] hw/intc/arm_gic: fix spurious level triggered interrupts, Peter Maydell, 2024/09/13
- [PULL 19/27] hw/net/can/xlnx-versal-canfd: Translate CAN ID registers, Peter Maydell, 2024/09/13
- [PULL 15/27] hvf: arm: Implement and use hvf_get_physical_address_range, Peter Maydell, 2024/09/13
- [PULL 07/27] hw: Use device_class_set_legacy_reset() instead of opencoding, Peter Maydell, 2024/09/13