[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH 27/31] DEBUG
From: |
Ani Sinha |
Subject: |
Re: [PATCH 27/31] DEBUG |
Date: |
Sat, 7 Dec 2024 09:08:31 +0530 |
On Fri, Dec 6, 2024 at 10:51 PM Mauro Carvalho Chehab
<mchehab+huawei@kernel.org> wrote:
>
> Signed-off-by: Mauro Carvalho Chehab <mchehab+huawei@kernel.org>
> ---
> hw/acpi/ghes.c | 2 ++
> 1 file changed, 2 insertions(+)
>
> diff --git a/hw/acpi/ghes.c b/hw/acpi/ghes.c
> index abca351b18de..1fe4c536611a 100644
> --- a/hw/acpi/ghes.c
> +++ b/hw/acpi/ghes.c
> @@ -534,9 +534,11 @@ void ghes_record_cper_errors(const void *cper, size_t
> len,
> ags = &acpi_ged_state->ghes_state;
>
> if (!ags->hest_lookup) {
> + fprintf(stderr,"Using old GHES lookup\n");
I don't like this. If you must please have them under #ifdef DEBUG or
somesuch. See ich9.c
> get_hw_error_offsets(le64_to_cpu(ags->hw_error_le),
> &cper_addr, &read_ack_register_addr);
> } else {
> + fprintf(stderr,"Using new HEST lookup\n");
> get_ghes_source_offsets(source_id, le64_to_cpu(ags->hest_addr_le),
> &cper_addr, &read_ack_register_addr, errp);
> }
> --
> 2.47.1
>
- [PATCH 10/31] acpi/ghes: better name GHES memory error function, (continued)
- [PATCH 10/31] acpi/ghes: better name GHES memory error function, Mauro Carvalho Chehab, 2024/12/06
- [PATCH 12/31] acpi/ghes: rename etc/hardware_error file macros, Mauro Carvalho Chehab, 2024/12/06
- [PATCH 03/31] acpi/ghes: simplify the per-arch caller to build HEST table, Mauro Carvalho Chehab, 2024/12/06
- [PATCH 07/31] acpi/ghes: Change the type for source_id, Mauro Carvalho Chehab, 2024/12/06
- [PATCH 31/31] FIXME: acpi/ghes: properly set data record size, Mauro Carvalho Chehab, 2024/12/06
- [PATCH 19/31] acpi/ghes: add a notifier to notify when error data is ready, Mauro Carvalho Chehab, 2024/12/06
- [PATCH 23/31] scripts/ghes_inject: add a script to generate GHES error inject, Mauro Carvalho Chehab, 2024/12/06
- [PATCH 27/31] DEBUG, Mauro Carvalho Chehab, 2024/12/06
- Re: [PATCH 27/31] DEBUG,
Ani Sinha <=
- [PATCH 21/31] arm/virt: Wire up a GED error device for ACPI / GHES, Mauro Carvalho Chehab, 2024/12/06
- [PATCH 18/31] acpi/generic_event_device: add logic to detect if HEST addr is available, Mauro Carvalho Chehab, 2024/12/06
- [PATCH 29/31] HACK: use GPIO as source ID for virt-9.1 machines, Mauro Carvalho Chehab, 2024/12/06
- [PATCH 20/31] acpi/generic_event_device: add an APEI error device, Mauro Carvalho Chehab, 2024/12/06
- [PATCH 16/31] acpi/ghes: Use HEST table offsets when preparing GHES records, Mauro Carvalho Chehab, 2024/12/06
- [PATCH 13/31] acpi/ghes: better name the offset of the hardware error firmware, Mauro Carvalho Chehab, 2024/12/06
- [PATCH 14/31] acpi/ghes: Prepare to support multiple sources on ghes, Mauro Carvalho Chehab, 2024/12/06
- [PATCH 24/31] target/arm: add an experimental mpidr arm cpu property object, Mauro Carvalho Chehab, 2024/12/06