[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v6 07/16] acpi/ghes: Change the type for source_id
From: |
Mauro Carvalho Chehab |
Subject: |
[PATCH v6 07/16] acpi/ghes: Change the type for source_id |
Date: |
Sat, 7 Dec 2024 09:54:13 +0100 |
As described at: ACPI 6.5 spec at:
18.3.2. ACPI Error Source
In particular at GHES/GHESv2 table:
Table 18.10 Generic Hardware Error Source Structure
HEST source ID is actually a 16-bit value.
Signed-off-by: Mauro Carvalho Chehab <mchehab+huawei@kernel.org>
Reviewed-by: Jonathan Cameron <Jonathan.Cameron@huawei.com>
Reviewed-by: Igor Mammedov <imammedo@redhat.com>
---
hw/acpi/ghes-stub.c | 2 +-
hw/acpi/ghes.c | 2 +-
include/hw/acpi/ghes.h | 2 +-
3 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/hw/acpi/ghes-stub.c b/hw/acpi/ghes-stub.c
index c315de1802d6..2b64cbd2819a 100644
--- a/hw/acpi/ghes-stub.c
+++ b/hw/acpi/ghes-stub.c
@@ -11,7 +11,7 @@
#include "qemu/osdep.h"
#include "hw/acpi/ghes.h"
-int acpi_ghes_record_errors(uint8_t source_id, uint64_t physical_address)
+int acpi_ghes_record_errors(uint16_t source_id, uint64_t physical_address)
{
return -1;
}
diff --git a/hw/acpi/ghes.c b/hw/acpi/ghes.c
index 5f67322bf0f2..edc74c38bf8a 100644
--- a/hw/acpi/ghes.c
+++ b/hw/acpi/ghes.c
@@ -383,7 +383,7 @@ void acpi_ghes_add_fw_cfg(AcpiGhesState *ags, FWCfgState *s,
ags->present = true;
}
-int acpi_ghes_record_errors(uint8_t source_id, uint64_t physical_address)
+int acpi_ghes_record_errors(uint16_t source_id, uint64_t physical_address)
{
uint64_t error_block_addr, read_ack_register_addr, read_ack_register = 0;
uint64_t start_addr;
diff --git a/include/hw/acpi/ghes.h b/include/hw/acpi/ghes.h
index 50e3a25ea384..9295e46be25e 100644
--- a/include/hw/acpi/ghes.h
+++ b/include/hw/acpi/ghes.h
@@ -73,7 +73,7 @@ void acpi_build_hest(GArray *table_data, GArray
*hardware_errors,
const char *oem_id, const char *oem_table_id);
void acpi_ghes_add_fw_cfg(AcpiGhesState *vms, FWCfgState *s,
GArray *hardware_errors);
-int acpi_ghes_record_errors(uint8_t source_id, uint64_t error_physical_addr);
+int acpi_ghes_record_errors(uint16_t source_id, uint64_t error_physical_addr);
/**
* acpi_ghes_present: Report whether ACPI GHES table is present
--
2.47.1
- [PATCH v6 00/16] Prepare GHES driver to support error injection, Mauro Carvalho Chehab, 2024/12/07
- [PATCH v6 04/16] acpi/ghes: better handle source_id and notification, Mauro Carvalho Chehab, 2024/12/07
- [PATCH v6 14/16] acpi/ghes: move offset calculus to a separate function, Mauro Carvalho Chehab, 2024/12/07
- [PATCH v6 16/16] docs: acpi_hest_ghes: fix documentation for CPER size, Mauro Carvalho Chehab, 2024/12/07
- [PATCH v6 03/16] acpi/ghes: simplify the per-arch caller to build HEST table, Mauro Carvalho Chehab, 2024/12/07
- [PATCH v6 01/16] acpi/ghes: get rid of ACPI_HEST_SRC_ID_RESERVED, Mauro Carvalho Chehab, 2024/12/07
- [PATCH v6 10/16] acpi/ghes: better name GHES memory error function, Mauro Carvalho Chehab, 2024/12/07
- [PATCH v6 02/16] acpi/ghes: simplify acpi_ghes_record_errors() code, Mauro Carvalho Chehab, 2024/12/07
- [PATCH v6 13/16] acpi/ghes: better name the offset of the hardware error firmware, Mauro Carvalho Chehab, 2024/12/07
- [PATCH v6 05/16] acpi/ghes: Fix acpi_ghes_record_errors() argument, Mauro Carvalho Chehab, 2024/12/07
- [PATCH v6 07/16] acpi/ghes: Change the type for source_id,
Mauro Carvalho Chehab <=
- [PATCH v6 11/16] acpi/ghes: don't crash QEMU if ghes GED is not found, Mauro Carvalho Chehab, 2024/12/07
- [PATCH v6 09/16] acpi/ghes: make the GHES record generation more generic, Mauro Carvalho Chehab, 2024/12/07
- [PATCH v6 08/16] acpi/ghes: don't check if physical_address is not zero, Mauro Carvalho Chehab, 2024/12/07
- [PATCH v6 06/16] acpi/ghes: Remove a duplicated out of bounds check, Mauro Carvalho Chehab, 2024/12/07
- [PATCH v6 12/16] acpi/ghes: rename etc/hardware_error file macros, Mauro Carvalho Chehab, 2024/12/07
- [PATCH v6 15/16] acpi/ghes: Change ghes fill logic to work with only one source, Mauro Carvalho Chehab, 2024/12/07