[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH v6 08/16] acpi/ghes: don't check if physical_address is not z
From: |
Igor Mammedov |
Subject: |
Re: [PATCH v6 08/16] acpi/ghes: don't check if physical_address is not zero |
Date: |
Mon, 9 Dec 2024 14:21:25 +0100 |
On Mon, 9 Dec 2024 11:36:40 +0000
Jonathan Cameron <Jonathan.Cameron@huawei.com> wrote:
> On Sat, 7 Dec 2024 09:54:14 +0100
> Mauro Carvalho Chehab <mchehab+huawei@kernel.org> wrote:
>
> > The 'physical_address' value is a faulty page. As such, 0 is
> > as valid as any other value.
> Still not sure on what faulty pages are :)
s/page/address/ probably would make it a bit more clear
>
> Given I tagged previous (after you'd sent this)
> Reviewed-by: Jonathan Cameron <Jonathan.Cameron@huawei.com>
>
> >
> > Suggested-by: Igor Mammedov <imammedo@redhat.com>
> > Signed-off-by: Mauro Carvalho Chehab <mchehab+huawei@kernel.org>
> > ---
> > hw/acpi/ghes.c | 4 ----
> > 1 file changed, 4 deletions(-)
> >
> > diff --git a/hw/acpi/ghes.c b/hw/acpi/ghes.c
> > index edc74c38bf8a..a3dffd78b012 100644
> > --- a/hw/acpi/ghes.c
> > +++ b/hw/acpi/ghes.c
> > @@ -400,10 +400,6 @@ int acpi_ghes_record_errors(uint16_t source_id,
> > uint64_t physical_address)
> >
> > start_addr = le64_to_cpu(ags->ghes_addr_le);
> >
> > - if (!physical_address) {
> > - return -1;
> > - }
> > -
> > start_addr += source_id * sizeof(uint64_t);
> >
> > cpu_physical_memory_read(start_addr, &error_block_addr,
>
- [PATCH v6 10/16] acpi/ghes: better name GHES memory error function, (continued)
- [PATCH v6 10/16] acpi/ghes: better name GHES memory error function, Mauro Carvalho Chehab, 2024/12/07
- [PATCH v6 02/16] acpi/ghes: simplify acpi_ghes_record_errors() code, Mauro Carvalho Chehab, 2024/12/07
- [PATCH v6 13/16] acpi/ghes: better name the offset of the hardware error firmware, Mauro Carvalho Chehab, 2024/12/07
- [PATCH v6 05/16] acpi/ghes: Fix acpi_ghes_record_errors() argument, Mauro Carvalho Chehab, 2024/12/07
- [PATCH v6 07/16] acpi/ghes: Change the type for source_id, Mauro Carvalho Chehab, 2024/12/07
- [PATCH v6 11/16] acpi/ghes: don't crash QEMU if ghes GED is not found, Mauro Carvalho Chehab, 2024/12/07
- [PATCH v6 09/16] acpi/ghes: make the GHES record generation more generic, Mauro Carvalho Chehab, 2024/12/07
- [PATCH v6 08/16] acpi/ghes: don't check if physical_address is not zero, Mauro Carvalho Chehab, 2024/12/07
- [PATCH v6 06/16] acpi/ghes: Remove a duplicated out of bounds check, Mauro Carvalho Chehab, 2024/12/07
- [PATCH v6 12/16] acpi/ghes: rename etc/hardware_error file macros, Mauro Carvalho Chehab, 2024/12/07
- [PATCH v6 15/16] acpi/ghes: Change ghes fill logic to work with only one source, Mauro Carvalho Chehab, 2024/12/07