[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PULL 01/22] tests/qtest: add TIMEOUT_MULTIPLIER
From: |
Fabiano Rosas |
Subject: |
[PULL 01/22] tests/qtest: add TIMEOUT_MULTIPLIER |
Date: |
Thu, 12 Dec 2024 12:09:28 -0300 |
From: Dmitry Frolov <frolov@swemel.ru>
Some tests need more time when qemu is built with
"--enable-asan --enable-ubsan"
As was discussed here:
https://patchew.org/QEMU/20241112120100.176492-2-frolov@swemel.ru/
TIMEOUT_MULTIPLIER enviroment variable will be
a useful option, allowing non-invasive timeouts
increasing for a specific build.
Signed-off-by: Dmitry Frolov <frolov@swemel.ru>
Tested-by: Fabiano Rosas <farosas@suse.de>
[changed from ifndef to ?=]
Signed-off-by: Fabiano Rosas <farosas@suse.de>
---
scripts/mtest2make.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/scripts/mtest2make.py b/scripts/mtest2make.py
index eb01a05ddb..2ef375fc6f 100644
--- a/scripts/mtest2make.py
+++ b/scripts/mtest2make.py
@@ -27,7 +27,7 @@ def names(self, base):
.speed.slow = $(foreach s,$(sort $(filter-out %-thorough, $1)), --suite $s)
.speed.thorough = $(foreach s,$(sort $1), --suite $s)
-TIMEOUT_MULTIPLIER = 1
+TIMEOUT_MULTIPLIER ?= 1
.mtestargs = --no-rebuild -t $(TIMEOUT_MULTIPLIER)
ifneq ($(SPEED), quick)
.mtestargs += --setup $(SPEED)
--
2.35.3
- [PULL 00/22] QTest patches for 2024-12-12, Fabiano Rosas, 2024/12/12
- [PULL 02/22] tests/qtest: Add qtest_system_reset() utility function, Fabiano Rosas, 2024/12/12
- [PULL 01/22] tests/qtest: add TIMEOUT_MULTIPLIER,
Fabiano Rosas <=
- [PULL 03/22] tests/qtest: Use qtest_system_reset() instead of open-coded versions, Fabiano Rosas, 2024/12/12
- [PULL 04/22] tests/qtest: Use qtest_system_reset_nowait() where appropriate, Fabiano Rosas, 2024/12/12
- [PULL 05/22] tests/qtest/migration: Standardize hook names, Fabiano Rosas, 2024/12/12
- [PULL 06/22] tests/qtest/migration: Stop calling everything "test", Fabiano Rosas, 2024/12/12
- [PULL 07/22] tests/migration: Disambiguate guestperf vs. a-b, Fabiano Rosas, 2024/12/12
- [PULL 08/22] tests/qtest/migration: Move bootfile code to its own file, Fabiano Rosas, 2024/12/12
- [PULL 09/22] tests/qtest/migration: Move qmp helpers to a separate file, Fabiano Rosas, 2024/12/12
- [PULL 10/22] tests/qtest/migration: Rename migration-helpers.c, Fabiano Rosas, 2024/12/12
- [PULL 11/22] tests/qtest/migration: Move ufd_version_check to utils, Fabiano Rosas, 2024/12/12
- [PULL 12/22] tests/qtest/migration: Move kvm_dirty_ring_supported to utils, Fabiano Rosas, 2024/12/12