[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH 3/5] hw/ppc/ppc4xx_pci: Use ARRAY_SIZE() instead of magic val
From: |
Cédric Le Goater |
Subject: |
Re: [PATCH 3/5] hw/ppc/ppc4xx_pci: Use ARRAY_SIZE() instead of magic value |
Date: |
Wed, 2 Sep 2020 08:53:12 +0200 |
User-agent: |
Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.11.0 |
On 9/1/20 12:40 PM, Philippe Mathieu-Daudé wrote:
> Replace the magic '4' by ARRAY_SIZE(s->irq) which is more explicit.
We could also define the 'irq' array with PCI_NUM_PINS instead of 4.
> Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org>
Reviewed-by: Cédric Le Goater <clg@kaod.org>
> ---
> hw/ppc/ppc4xx_pci.c | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/hw/ppc/ppc4xx_pci.c b/hw/ppc/ppc4xx_pci.c
> index 3ea47df71fe..cd3f192a138 100644
> --- a/hw/ppc/ppc4xx_pci.c
> +++ b/hw/ppc/ppc4xx_pci.c
> @@ -320,7 +320,8 @@ static void ppc4xx_pcihost_realize(DeviceState *dev,
> Error **errp)
>
> b = pci_register_root_bus(dev, NULL, ppc4xx_pci_set_irq,
> ppc4xx_pci_map_irq, s->irq,
> get_system_memory(),
> - get_system_io(), 0, 4, TYPE_PCI_BUS);
> + get_system_io(), 0, ARRAY_SIZE(s->irq),
> + TYPE_PCI_BUS);
> h->bus = b;
>
> pci_create_simple(b, 0, "ppc4xx-host-bridge");
>
- [PATCH 0/5] hw: Replace some impossible checks by assertions, Philippe Mathieu-Daudé, 2020/09/01
- [PATCH 1/5] hw/gpio/max7310: Remove impossible check, Philippe Mathieu-Daudé, 2020/09/01
- [PATCH 2/5] hw/mips/fuloong2e: Convert pointless error message to an assert(), Philippe Mathieu-Daudé, 2020/09/01
- [PATCH 3/5] hw/ppc/ppc4xx_pci: Use ARRAY_SIZE() instead of magic value, Philippe Mathieu-Daudé, 2020/09/01
- [PATCH 4/5] hw/ppc/ppc4xx_pci: Replace pointless warning by assert(), Philippe Mathieu-Daudé, 2020/09/01
- [PATCH 5/5] hw/isa/isa-bus: Replace hw_error() by assert(), Philippe Mathieu-Daudé, 2020/09/01