[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH 2/5] hw/mips/fuloong2e: Convert pointless error message to an
From: |
Laurent Vivier |
Subject: |
Re: [PATCH 2/5] hw/mips/fuloong2e: Convert pointless error message to an assert() |
Date: |
Wed, 9 Sep 2020 15:23:07 +0200 |
User-agent: |
Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.11.0 |
Le 01/09/2020 à 12:40, Philippe Mathieu-Daudé a écrit :
> Displaying "vt82c686b_init error" doesn't give any hint about why
> this call failed. As this message targets developers and not users,
> replace the pointless error message by a call to assert() which
> will provide more useful information.
>
> Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org>
> ---
> hw/mips/fuloong2e.c | 5 +----
> 1 file changed, 1 insertion(+), 4 deletions(-)
>
> diff --git a/hw/mips/fuloong2e.c b/hw/mips/fuloong2e.c
> index 8ca31e5162c..f28609976bf 100644
> --- a/hw/mips/fuloong2e.c
> +++ b/hw/mips/fuloong2e.c
> @@ -240,10 +240,7 @@ static void vt82c686b_southbridge_init(PCIBus *pci_bus,
> int slot, qemu_irq intc,
> PCIDevice *dev;
>
> isa_bus = vt82c686b_isa_init(pci_bus, PCI_DEVFN(slot, 0));
> - if (!isa_bus) {
> - fprintf(stderr, "vt82c686b_init error\n");
> - exit(1);
> - }
> + assert(isa_bus);
> *p_isa_bus = isa_bus;
> /* Interrupt controller */
> /* The 8259 -> IP5 */
>
Applied to my trivial-patches branch.
Thanks,
Laurent
- [PATCH 0/5] hw: Replace some impossible checks by assertions, Philippe Mathieu-Daudé, 2020/09/01
- [PATCH 1/5] hw/gpio/max7310: Remove impossible check, Philippe Mathieu-Daudé, 2020/09/01
- [PATCH 2/5] hw/mips/fuloong2e: Convert pointless error message to an assert(), Philippe Mathieu-Daudé, 2020/09/01
- [PATCH 3/5] hw/ppc/ppc4xx_pci: Use ARRAY_SIZE() instead of magic value, Philippe Mathieu-Daudé, 2020/09/01
- [PATCH 4/5] hw/ppc/ppc4xx_pci: Replace pointless warning by assert(), Philippe Mathieu-Daudé, 2020/09/01
- [PATCH 5/5] hw/isa/isa-bus: Replace hw_error() by assert(), Philippe Mathieu-Daudé, 2020/09/01