[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v7 36/61] target/ppc/mmu_common.c: Remove local name for a consta
From: |
BALATON Zoltan |
Subject: |
[PATCH v7 36/61] target/ppc/mmu_common.c: Remove local name for a constant |
Date: |
Mon, 13 May 2024 01:28:10 +0200 (CEST) |
The mmask local variable is a less descriptive local name for a
constant. Drop it and use the constant directly in the two places it
is needed.
Signed-off-by: BALATON Zoltan <balaton@eik.bme.hu>
---
target/ppc/mmu_common.c | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/target/ppc/mmu_common.c b/target/ppc/mmu_common.c
index 9e0bfbda67..5d0090014a 100644
--- a/target/ppc/mmu_common.c
+++ b/target/ppc/mmu_common.c
@@ -98,7 +98,7 @@ static int ppc6xx_tlb_pte_check(mmu_ctx_t *ctx, target_ulong
pte0,
target_ulong pte1, int h,
MMUAccessType access_type)
{
- target_ulong ptem, mmask;
+ target_ulong ptem;
int ret, pteh, ptev, pp;
ret = -1;
@@ -108,12 +108,11 @@ static int ppc6xx_tlb_pte_check(mmu_ctx_t *ctx,
target_ulong pte0,
if (ptev && h == pteh) {
/* Check vsid & api */
ptem = pte0 & PTE_PTEM_MASK;
- mmask = PTE_CHECK_MASK;
pp = pte1 & 0x00000003;
if (ptem == ctx->ptem) {
if (ctx->raddr != (hwaddr)-1ULL) {
/* all matches should have equal RPN, WIMG & PP */
- if ((ctx->raddr & mmask) != (pte1 & mmask)) {
+ if ((ctx->raddr & PTE_CHECK_MASK) != (pte1 & PTE_CHECK_MASK)) {
qemu_log_mask(CPU_LOG_MMU, "Bad RPN/WIMG/PP\n");
return -3;
}
--
2.30.9
- [PATCH v7 31/61] target/ppc/mmu-hash32.c: Drop a local variable, (continued)
- [PATCH v7 31/61] target/ppc/mmu-hash32.c: Drop a local variable, BALATON Zoltan, 2024/05/12
- [PATCH v7 32/61] target/ppc/mmu-radix64.c: Drop a local variable, BALATON Zoltan, 2024/05/12
- [PATCH v7 35/61] target/ppc: Remove pp_check() and reuse ppc_hash32_pp_prot(), BALATON Zoltan, 2024/05/12
- [PATCH v7 37/61] target/ppc/mmu_common.c: Remove single use local variable, BALATON Zoltan, 2024/05/12
- [PATCH v7 39/61] target/ppc/mmu_common.c: Remove another single use local, BALATON Zoltan, 2024/05/12
- [PATCH v7 33/61] target/ppc: Add a function to check for page protection bit, BALATON Zoltan, 2024/05/12
- [PATCH v7 41/61] target/ppc/mmu_common.c: Return directly in ppc6xx_tlb_pte_check(), BALATON Zoltan, 2024/05/12
- [PATCH v7 36/61] target/ppc/mmu_common.c: Remove local name for a constant,
BALATON Zoltan <=
- [PATCH v7 38/61] target/ppc/mmu_common.c: Remove single use local variable, BALATON Zoltan, 2024/05/12
- [PATCH v7 40/61] target/ppc/mmu_common.c: Remove yet another single use local, BALATON Zoltan, 2024/05/12
- [PATCH v7 42/61] target/ppc/mmu_common.c: Simplify ppc6xx_tlb_pte_check(), BALATON Zoltan, 2024/05/12
- [PATCH v7 43/61] target/ppc/mmu_common.c: Remove unused field from mmu_ctx_t, BALATON Zoltan, 2024/05/12
- [PATCH v7 44/61] target/ppc/mmu_common.c: Remove hash field from mmu_ctx_t, BALATON Zoltan, 2024/05/12
- [PATCH v7 51/61] target/ppc: Add function to get protection key for hash32 MMU, BALATON Zoltan, 2024/05/12
- [PATCH v7 52/61] target/ppc/mmu-hash32.c: Inline and remove ppc_hash32_pte_prot(), BALATON Zoltan, 2024/05/12