qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [PATCH v8 06/54] Rename mis->file to from_src_file


From: Dr. David Alan Gilbert (git)
Subject: [Qemu-devel] [PATCH v8 06/54] Rename mis->file to from_src_file
Date: Tue, 29 Sep 2015 09:37:30 +0100

From: "Dr. David Alan Gilbert" <address@hidden>

'file' becomes confusing when you have flows in each direction;
rename to make it clear.
This leaves just the main forward direction ms->file, which is used
in a lot of places and is probably not worth renaming given the churn.

Signed-off-by: Dr. David Alan Gilbert <address@hidden>
---
 include/migration/migration.h | 2 +-
 migration/migration.c         | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/include/migration/migration.h b/include/migration/migration.h
index 8334621..83fba23 100644
--- a/include/migration/migration.h
+++ b/include/migration/migration.h
@@ -48,7 +48,7 @@ typedef QLIST_HEAD(, LoadStateEntry) LoadStateEntry_Head;
 
 /* State for the incoming migration */
 struct MigrationIncomingState {
-    QEMUFile *file;
+    QEMUFile *from_src_file;
 
     /* See savevm.c */
     LoadStateEntry_Head loadvm_handlers;
diff --git a/migration/migration.c b/migration/migration.c
index 662e77e..192e975 100644
--- a/migration/migration.c
+++ b/migration/migration.c
@@ -87,7 +87,7 @@ MigrationIncomingState *migration_incoming_get_current(void)
 MigrationIncomingState *migration_incoming_state_new(QEMUFile* f)
 {
     mis_current = g_malloc0(sizeof(MigrationIncomingState));
-    mis_current->file = f;
+    mis_current->from_src_file = f;
     QLIST_INIT(&mis_current->loadvm_handlers);
 
     return mis_current;
-- 
2.5.0




reply via email to

[Prev in Thread] Current Thread [Next in Thread]