[Top][All Lists]
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Libunwind-devel] [PATCH 11/57] IA64: avoid -Wunused-but-set-variable in
From: |
Tommi Rantala |
Subject: |
[Libunwind-devel] [PATCH 11/57] IA64: avoid -Wunused-but-set-variable in src/ia64/init.h |
Date: |
Fri, 21 Sep 2012 14:11:12 +0300 |
In file included from src/ia64/Ginit_remote.c:26:0:
src/ia64/init.h: In function 'common_init':
src/ia64/init.h:32:12: warning: variable 'natp' set but not used
[-Wunused-but-set-variable]
---
src/ia64/init.h | 10 ++++------
1 file changed, 4 insertions(+), 6 deletions(-)
diff --git a/src/ia64/init.h b/src/ia64/init.h
index d6a1b22..1f3f956 100644
--- a/src/ia64/init.h
+++ b/src/ia64/init.h
@@ -29,7 +29,6 @@ static ALWAYS_INLINE int
common_init (struct cursor *c, unw_word_t sp, unw_word_t bsp)
{
unw_word_t bspstore, rbs_base;
- uint8_t *natp;
int ret;
if (c->as->caching_policy != UNW_CACHE_NONE)
@@ -53,11 +52,10 @@ common_init (struct cursor *c, unw_word_t sp, unw_word_t
bsp)
c->loc[IA64_REG_R6] = IA64_REG_LOC (c, UNW_IA64_GR + 6);
c->loc[IA64_REG_R7] = IA64_REG_LOC (c, UNW_IA64_GR + 7);
- natp = c->nat_bitnr;
- c->loc[IA64_REG_NAT4] = IA64_REG_NAT_LOC (c, UNW_IA64_NAT + 4, &natp[0]);
- c->loc[IA64_REG_NAT5] = IA64_REG_NAT_LOC (c, UNW_IA64_NAT + 5, &natp[1]);
- c->loc[IA64_REG_NAT6] = IA64_REG_NAT_LOC (c, UNW_IA64_NAT + 6, &natp[2]);
- c->loc[IA64_REG_NAT7] = IA64_REG_NAT_LOC (c, UNW_IA64_NAT + 7, &natp[3]);
+ c->loc[IA64_REG_NAT4] = IA64_REG_NAT_LOC (c, UNW_IA64_NAT + 4,
&c->nat_bitnr[0]);
+ c->loc[IA64_REG_NAT5] = IA64_REG_NAT_LOC (c, UNW_IA64_NAT + 5,
&c->nat_bitnr[1]);
+ c->loc[IA64_REG_NAT6] = IA64_REG_NAT_LOC (c, UNW_IA64_NAT + 6,
&c->nat_bitnr[2]);
+ c->loc[IA64_REG_NAT7] = IA64_REG_NAT_LOC (c, UNW_IA64_NAT + 7,
&c->nat_bitnr[3]);
c->loc[IA64_REG_B1] = IA64_REG_LOC (c, UNW_IA64_BR + 1);
c->loc[IA64_REG_B2] = IA64_REG_LOC (c, UNW_IA64_BR + 2);
--
1.7.9.5
- [Libunwind-devel] [PATCH 15/57] HPPA: kludge out unused variable in unw_get_save_loc() stub, (continued)
- [Libunwind-devel] [PATCH 15/57] HPPA: kludge out unused variable in unw_get_save_loc() stub, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 05/57] Align `sos_memory' to MAX_ALIGN, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 10/57] Apply UNW_ALIGN more in src/mi/mempool.c, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 13/57] PPC: remove unused `PAGE_START' macro from Ginit.c, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 09/57] Invert tdep_init() flag logic, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 14/57] HPPA: properly check dwarf_get() return value in unw_step(), Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 17/57] Clear out `ip' to avoid -Wuninitialized warning in tests/test-coredump-unwind.c, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 20/57] Annotate potentially unused variable in tests/Gtest-bt.c, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 12/57] Remove unused src/x86_64/Lis_signal_frame.c, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 16/57] Default to non-verbose mode in Ltest-cxx-exceptions, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 11/57] IA64: avoid -Wunused-but-set-variable in src/ia64/init.h,
Tommi Rantala <=
- [Libunwind-devel] [PATCH 18/57] Avoid -Wunused-value warning in tests/Gia64-test-stack.c, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 26/57] Cleanup dynamically allocated memory before exit in tests, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 19/57] Workaround volatileness warning in tests/ia64-test-setjmp.c, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 21/57] Annotate potentially unused variable in tests/Gtest-trace.c, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 22/57] Annotate potentially unused variable in tests/test-coredump-unwind.c, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 24/57] Rename `test-varargs' to `Ltest-varargs', Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 29/57] Roll `test-nocalloc' into `Ltest-nocalloc.c', Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 27/57] Rename `rs-race' to `Lrs-race', Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 28/57] Call `unw_backtrace()' explicitly in test-flush-cache.c, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 25/57] Remove unneeded `config.h' inclusion in Gtest-nomalloc, Tommi Rantala, 2012/09/21