[Top][All Lists]
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Libunwind-devel] [PATCH 21/57] Annotate potentially unused variable in
From: |
Tommi Rantala |
Subject: |
[Libunwind-devel] [PATCH 21/57] Annotate potentially unused variable in tests/Gtest-trace.c |
Date: |
Fri, 21 Sep 2012 14:11:22 +0300 |
tests/Gtest-trace.c: In function 'sighandler':
tests/Gtest-trace.c:179:15: warning: unused variable 'uc' [-Wunused-variable]
---
tests/Gtest-trace.c | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/tests/Gtest-trace.c b/tests/Gtest-trace.c
index 5145e65..9d43ce2 100644
--- a/tests/Gtest-trace.c
+++ b/tests/Gtest-trace.c
@@ -24,6 +24,8 @@ WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
SOFTWARE. */
# include "config.h"
#endif
+#include "compiler.h"
+
#include <errno.h>
#if HAVE_EXECINFO_H
# include <execinfo.h>
@@ -176,9 +178,11 @@ bar (long v)
void
sighandler (int signal, void *siginfo __attribute__((unused)), void *context)
{
- ucontext_t *uc = context;
+ ucontext_t *uc UNUSED;
int sp;
+ uc = context;
+
if (verbose)
{
printf ("sighandler: got signal %d, sp=%p", signal, &sp);
--
1.7.9.5
- [Libunwind-devel] [PATCH 09/57] Invert tdep_init() flag logic, (continued)
- [Libunwind-devel] [PATCH 09/57] Invert tdep_init() flag logic, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 14/57] HPPA: properly check dwarf_get() return value in unw_step(), Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 17/57] Clear out `ip' to avoid -Wuninitialized warning in tests/test-coredump-unwind.c, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 20/57] Annotate potentially unused variable in tests/Gtest-bt.c, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 12/57] Remove unused src/x86_64/Lis_signal_frame.c, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 16/57] Default to non-verbose mode in Ltest-cxx-exceptions, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 11/57] IA64: avoid -Wunused-but-set-variable in src/ia64/init.h, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 18/57] Avoid -Wunused-value warning in tests/Gia64-test-stack.c, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 26/57] Cleanup dynamically allocated memory before exit in tests, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 19/57] Workaround volatileness warning in tests/ia64-test-setjmp.c, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 21/57] Annotate potentially unused variable in tests/Gtest-trace.c,
Tommi Rantala <=
- [Libunwind-devel] [PATCH 22/57] Annotate potentially unused variable in tests/test-coredump-unwind.c, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 24/57] Rename `test-varargs' to `Ltest-varargs', Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 29/57] Roll `test-nocalloc' into `Ltest-nocalloc.c', Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 27/57] Rename `rs-race' to `Lrs-race', Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 28/57] Call `unw_backtrace()' explicitly in test-flush-cache.c, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 25/57] Remove unneeded `config.h' inclusion in Gtest-nomalloc, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 23/57] Drop `optimize' attribute in tests/test-varargs.c, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 30/57] Call snprintf() from signal handler only if required in test-async-sig, Tommi Rantala, 2012/09/21