[Top][All Lists]
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[Libunwind-devel] [PATCH 19/57] Workaround volatileness warning in tests
From: |
Tommi Rantala |
Subject: |
[Libunwind-devel] [PATCH 19/57] Workaround volatileness warning in tests/ia64-test-setjmp.c |
Date: |
Fri, 21 Sep 2012 14:11:20 +0300 |
tests/ia64-test-setjmp.c:76: warning: function return types not compatible due
to 'volatile'
---
tests/ia64-test-setjmp.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/tests/ia64-test-setjmp.c b/tests/ia64-test-setjmp.c
index be487b6..50eaa01 100644
--- a/tests/ia64-test-setjmp.c
+++ b/tests/ia64-test-setjmp.c
@@ -73,7 +73,8 @@ sighandler (int signal, void *siginfo, void *sigcontext)
/* Direct call of doit () at the end of doit () would get optimized by GCC to
a branch. */
static void doit (int n);
-static volatile void (*doit_pointer) (int n) = doit;
+typedef void (*doit_type) (int);
+static volatile doit_type doit_pointer = doit;
static void
doit (int n)
--
1.7.9.5
- [Libunwind-devel] [PATCH 13/57] PPC: remove unused `PAGE_START' macro from Ginit.c, (continued)
- [Libunwind-devel] [PATCH 13/57] PPC: remove unused `PAGE_START' macro from Ginit.c, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 09/57] Invert tdep_init() flag logic, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 14/57] HPPA: properly check dwarf_get() return value in unw_step(), Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 17/57] Clear out `ip' to avoid -Wuninitialized warning in tests/test-coredump-unwind.c, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 20/57] Annotate potentially unused variable in tests/Gtest-bt.c, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 12/57] Remove unused src/x86_64/Lis_signal_frame.c, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 16/57] Default to non-verbose mode in Ltest-cxx-exceptions, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 11/57] IA64: avoid -Wunused-but-set-variable in src/ia64/init.h, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 18/57] Avoid -Wunused-value warning in tests/Gia64-test-stack.c, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 26/57] Cleanup dynamically allocated memory before exit in tests, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 19/57] Workaround volatileness warning in tests/ia64-test-setjmp.c,
Tommi Rantala <=
- [Libunwind-devel] [PATCH 21/57] Annotate potentially unused variable in tests/Gtest-trace.c, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 22/57] Annotate potentially unused variable in tests/test-coredump-unwind.c, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 24/57] Rename `test-varargs' to `Ltest-varargs', Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 29/57] Roll `test-nocalloc' into `Ltest-nocalloc.c', Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 27/57] Rename `rs-race' to `Lrs-race', Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 28/57] Call `unw_backtrace()' explicitly in test-flush-cache.c, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 25/57] Remove unneeded `config.h' inclusion in Gtest-nomalloc, Tommi Rantala, 2012/09/21
- [Libunwind-devel] [PATCH 23/57] Drop `optimize' attribute in tests/test-varargs.c, Tommi Rantala, 2012/09/21