lilypond-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Improve implementation of dashed slurs


From: Carl D. Sorensen
Subject: Re: Improve implementation of dashed slurs
Date: Sat, 18 Apr 2009 08:43:07 -0600



On 4/17/09 10:20 PM, "Carl Sorensen" <address@hidden> wrote:

> 
> 
> 
> On 4/17/09 1:47 PM, "address@hidden" <address@hidden> wrote:
> 
>> 
>> http://codereview.appspot.com/41099/diff/1021/59
>> File lily/bezier.cc (right):
>> 
>> http://codereview.appspot.com/41099/diff/1021/59#newcode275
>> Line 275: Bezier::subdivide (Real t, Bezier &left_part, Bezier
>> &right_part)
>> We only use references if they are const (for clarity), so please change
>> the arguments to pointers. Also, this function can be marked as const.
> 
> So, if I understand right, you want
> Bezier::subdivide (Real t, Bezier *left_part, Bezier *right_part) const
> 
> and then in the code, instead of
> 
> left_part.control_[i]=
> 
> I do
> 
> *left_part.control_[i]=
> 
> Is this right?
> 
> 
> But when I try this, I get compile errors.
> 
> Can you give me a summary of how this works properly with classes?  The syntax
> I used previously is what I have used in the past.
> 

Never mind.  I found it out:  I use left_part->control_[i] instead of
*left_part.control_[i].

Sorry for the noise.

Carl





reply via email to

[Prev in Thread] Current Thread [Next in Thread]