octave-maintainers
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Setting the fontname and size of text


From: Shai Ayal
Subject: Re: Setting the fontname and size of text
Date: Wed, 14 Nov 2007 21:56:09 +0200

On Nov 13, 2007 8:33 PM, Shai Ayal <address@hidden> wrote:
>
> On Nov 13, 2007 5:16 PM, John W. Eaton <address@hidden> wrote:
> > On 13-Nov-2007, David Bateman wrote:
> >
> > | Shai Ayal wrote:
> > | > David,
> > | >
> > | > I wish you would use the radio_value class for these properties. That
> > | > way you would gain automatic validity checks. I'll try to submit a
> > | > patch tonight if you don't beat me to it
> > | >
> > | > Shai
> > | >
> > | >
> > | Ok, then what about the attached..
> >
> > Thanks, I applied this patch and checked it in.
> >
> > Note that yesterday I extracted the
> >
> >   if (isempty (t.fontname))
> >     f = "Helvetica";
> >   else
> >     f = t.fontname;
> >   endif
> >   if (isempty (t.fontsize))
> >     s = 10;
> >   else
> >     s = t.fontsize;
> >   endif
> >
> > into a separate subfunction to avoid duplicating these lines several
> > times, so I applied your changes to __go_draw_axes__.m to that
> > function by hand.
> >
> > jwe
> >
>
> I attach a patch which deletes the string_property class since it has
> the same functionality as the radio_property class.
> It fixes the bug in radio_property so now it is case-insensitive.
> to do this it reuses the property_name class renaming it to the more
> generic name caseless_str
>
> I am sending the patch w/o even checking that it compiles. I am
> compiling right now, but on my old laptop which I use for development
> it will take me ~2hours, so It might be much faser to apply the patch
> and find any minor syntax errors on your side.

OK, I managed to get that compile done. The previous patch was no
good. I attach a working version.

Shai


 2007-11-13  Shai Ayal  <address@hidden>

         * graphics.cc (string_properties): delete class
         (property_name): rename class to caseless_str
         (radio_values::possible_vals): change type to  caseless_str

Attachment: string_property2radio_property.patch.gz
Description: GNU Zip compressed data


reply via email to

[Prev in Thread] Current Thread [Next in Thread]